No announcement yet.

Enabling XvMC on G965? What is supported?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Enabling XvMC on G965? What is supported?

    I recently re-installed Linux on an old DG965RY motherboard, to use as a MythTV frontend among other things.

    I am trying to figure out the current state of video acceleration for Intel chipsets in general, and my board/GPU specifically. Because of the changing state of the drivers, I have found a lot of contradictory information, (I have seen reports of: No XvMC support, Only i815 support, only MC acceleration, XVMC but not for HD, and full XvMC). Is there someplace that has the current state of video acceleration summarized?

    Mainly, I'm wondering if my G965 GPU can support HD MPEG2 acceleration with MythTV.

    If so, any pointers for enabling + configuring this?

  • #2
    AFAIK XvMC will only do MPEG1 and 2 so mentioned HD is out of the question (unless you actually have some high resolution material in MPEG1 or 2). And as far as I remember (would it be AFAIR?) the last time intel's XvMC worked it worked only with overlay output and not with textured video, which seems to be the way to go. Anyway, decoding MPEG1 or 2 can't really get a PIII 500MHz flooded with work so I don't think we need XvMC with it's current decoding capabilites at all.


    • #3
      I am in the U.S., where MPEG-2 is used in the broadcast D-TV / HDTV standard format called ATSC. So, I've got plenty of 1080i and 720p HD material to play via my MythTV DVR.

      So, XvMC is what I'm looking for. Anyone else here using it with their Intel GPU?


      • #4
        it's undergoing heavy changes and has even been pulled from git master in the name of stabilizing things. there's experimental patches on the intel-gfx mailing list to enable it under DRI2/UXA that worked last I checked it a week or two ago. I think they're working on making it work with GEM right now before it gets put back in the driver, so you'll have to be patient. There is a xvmc-vld branch on their git you could probably build if you wanted to mess with it under the older it's based on.


        • #5
          Thanks for the response, Sarvatt. That's great info.

          I will look into building my own driver, with XvMC enabled.

          VLD support would be nice, but according to the table on this page: my G965 / X3000 doesn't support VLD. But, it does support iDCT + MC, so it will still be a good offload.


          • #6
            Oh I'm sorry, I thought I read you had a 4500 for some strange reason.. Must have been reading another thread at the same time It should work fine in 2.7.0 or 2.7.1 under EXA in both textured and overlay, what problems specifically do you have? The best place to ask would be #intel-gfx on the freenode irc server, my only intel video is 945GME which has crap for acceleration so I haven't looked into it much. It was disabled in UXA awhile back but that's the only limitation I see.


            • #7
              My X log showed that XvMC was disabled, even though I had enabled it in xorg.conf, so I was first trying to verify XvMC was possible before digging in and trying to debug it.

              I was testing it on a newly installed Ubuntu 9.04 system, which is using UXA (when I configured the xorg.conf to specify the intel driver and enable XvMC, I got only a blue display. After enabling UXA in xorg.conf, everything displayed properly).

              I have been using a Mac Mini for my Myth frontend for a couple years now, and Linux on the server/backend side. So, my X11 knowledge is dated.. I need to do some research to even understand what UXA and the other new variables are all about. But, this will be a good project to ramp back up. I'll check into the UXA patches you mentioned and see how that goes.



              • #8
                I would just try EXA on 2.7.1 drivers first to see if it works, you can add the sources here to get the drivers for jaunty

                If that doesn't work let me know and I'll dig up a patch and build it on a PPA for you, been meaning to do that anyhow to mess around with it some.


                • #9
                  Thanks, I tried EXA last night (I didn't realize the single driver supported both modes).

                  I also didn't have the correct Intel XvMC library referenced in /etc/X11/XvMCConfig, so I changed that.

                  The Xorg log now showed XvMC as being enabled.

                  Initially when I tried to play HD content, Mythfrontend crashed. After some googling, I found a note saying to only use one core for decoding, not two. So, I changed the MythTV settings, and tried again. But, the system locked up solid when I tried to play a video. This was late last night, so I didn't do much debugging. I'll play around with it some more this weekend.

                  Thanks for the help.


                  • #10
                    Tried going to system -- preferences -- multimedia systems selector and changing the output device on the video tab? Try intel textured video if it was on intel overlay specifically.