Announcement

Collapse
No announcement yet.

Motherboard with *working* USB chipsets

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Motherboard with *working* USB chipsets

    Hello all!

    First of all I apologise about the subject title. I know it looks odd but I'm pretty much close to pulling my hair out at this point. First of all let me explain.

    I'm having some nasty USB 2/3 problems on the current system I own. It is a MSI Z97 Gaming 3 motherboard system with 32GB (DDR3) ram and an i7-4790 CPU. But it has some *major* usb issues (I've tried updating the bios, although there's no new bios updates post 2016). The OS is debian stretch but I've also tried buster too and have exactly the same problem.

    The problem is that some of the USB ports seem to be getting initalised "late" - so once I get to the login screen (not grub) for debian (I'm using KDE) the keyboard and mouse do not respond at all also a couple of other devices (all plugged into the motherboards' USB sockets at the rear) seem to initalise "late" as well - a technisat USB satellite receiver device (which eventually works) and a USB to ethernet device - which fails. I then get errors about xhci not initalising properly or timing out in dmesg.

    So far the only workaround I've found is to disable "legacy usb" in the bios for this motherboard. But then I can't do anything in grub (apart from waiting for it to time out and load) and neither can I boot from a USB device if I disable legacy usb in this motherboards' bios (yes, it actually *needs* this option to do this - !).

    From what I have been able to read about this motherboard online (and I understand it isn't exactcly the latest motherboard out there) is that apparently the chipset used on this motherboard isn't just an intel chipset - there is some sort of renesas (usb) chipset on there as well and apparently this chipset isn't what you'd call 100%....from memory of what I read it dosen't even completely work right in window$(!).

    So here's my thought. Is there a known good x97 motherboard that can take my CPU and RAM - but actually have a *working* USB chipset instead of this renesas cheap chinese tat? Or should I just forget this entire setup (I was under the impression that the i7-4790 was still a relatively fast CPU) and go with something newer (eg a Ryzen 7 or threadripper)?

    Can anyone help out there? Many thanks!

    ljones

  • #2
    GRUB does not need USB legacy support. It comes with its own USB drivers. For that, ensure that GRUB_TERMINAL_INPUT="usb_keyboard" and GRUB_PRELOAD_MODULES="usb usb_keyboard ohci uhci ehci" are set in your grub configuration.

    Do note that due to lack of XHCI support in GRUB, the keyboard needs to be connected to a USB 2 port, not a USB 3 port.

    Comment

    Working...
    X