No announcement yet.

Offline install wanting to install older versions of tests

  • Filter
  • Time
  • Show
Clear All
new posts

  • Offline install wanting to install older versions of tests

    I am trying to run the test suite on an offline environment, so I have configured for enterprise-setup with networking off. I have run some tests on my internet-connected environment, and then run make-download-cache and make-openbenchmarking-cache, and copied the directories over. Ideally I'd run everything from the local directory even as root, so I have tried copying them to my local phoronix-test-suite directory and setting PTS_USER_PATH_OVERRIDE, as well as copying them to /var/lib/phoronix-test-suite. The problem I am facing is on the internet connected environment it installs/runs the latest versions of tests. In the offline environment it wants to install/run old versions of the tests. How can I get the offline PC to run the same versions as the connected environment?

    Connected PC:
    [strandd@fedora-33-shared phoronix-test-suite]$ ./phoronix-test-suite debug-install fio

    To Install: pts/fio-2.1.0
    Installing Test: pts/fio-2.1.0
    Downloading Files: pts/fio-2.1.0
    <continues to install>

    [strandd@fedora-33-shared phoronix-test-suite]$ find ~/.phoronix-test-suite/ -name "fio-2.1.0"

    Offline PC:
    [root@cs1 phoronix-test-suite]# export PTS_USER_PATH_OVERRIDE=/home/phoronix-lru-setup/phoronix-test-suite/
    [root@cs1 phoronix-test-suite]# ./phoronix-test-suite debug-install fio

    Internet Communication Is Disabled Per Your User Configuration.

    To Install: pts/fio-1.15.0
    Installing Test: pts/fio-1.15.0
    Downloading Files: pts/fio-1.15.0
    Internet support is needed to acquire files and it's disabled or not available.

    Downloading of needed test files failed.

    [root@cs1 phoronix-test-suite]# find . -name "fio-2.1.0"

    [root@cs1 phoronix-test-suite]# find /var/lib/phoronix-test-suite/ -name "fio-2.1.0"

  • #2
    I found that it wants the directory to be in /var/cache/phoronix-test-suite rather than /var/lib/ or the local directory.

    Note: I am trying to get everything to come from the local directory because /var is in a ramdisk on this offline environment. I am setting the following:
    ./phoronix-test-suite enterprise-setup
    ./phoronix-test-suite user-config-set EnvironmentDirectory=$(pwd)/installed-tests/
    ./phoronix-test-suite user-config-set CacheDirectory=$(pwd)/download-cache/
    ./phoronix-test-suite user-config-set ResultsDirectory=$(pwd)/test-results/
    ./phoronix-test-suite user-config-set PhoromaticStorage=$(pwd)/phoromatic/
    export PTS_USER_PATH_OVERRIDE="$(pwd)/"

    Perhaps I missed it, is there a variable or config to override the cache directory location?
    Last edited by dpstrand; 16 April 2024, 05:31 PM.