Announcement

Collapse
No announcement yet.

Intel Broadwell-U P-State vs. ACPI CPUFreq Scaling Linux Performance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Kano
    Kanotix Developer

  • Kano
    replied
    You can not use ondemand when this does not exists. As cpufrequtils seems a bit outdated you have to force your luck! The code is inside /etc/init.d in case you are wondering. By default your kernel activates performance mode, that startscript is used to set another one. Thats why you don't need to write a script but just a config file. You should complain maybe against cpufrequtils but not about pstate driver if you use it the wrong way...

    Leave a comment:

  • Tares
    Senior Member

  • Tares
    replied
    Originally posted by Kano View Post
    Before you complain look at the code!!! pstate is not the problem!
    I do not complain. Just wondering what is it about. I understand the code this way, that it tells the cpufrequtils to turn on "powersave" mode instead of "ondemand". I don't understand how that suppose to help with p-state driver, since before I've installed cpufrequtils there were no /etc/default/cpufrequtils.

    Leave a comment:

  • GreatEmerald
    Senior Member

  • GreatEmerald
    replied
    Again, why would you (if all hardware and software behaves properly) ever use anything other than P-state performance?

    Leave a comment:

  • Kano
    Kanotix Developer

  • Kano
    replied
    The main difference is that you don't need a tool like i7z to see the real cpu frequency in case of turbo boost. With old code turbo boost only was shown in /proc/cpuinfo as +1 MHz.

    Leave a comment:

  • StefanBruens
    Senior Member

  • StefanBruens
    replied
    Please improve color coding of result table!

    Currently the tables show the best value in green and the worst one in red.

    Please:
    - if the difference between best and worst is less than 1%, do not highlight any
    - show any result with 99,5% of the best result in green as well.
    - show any result with no more than 100,5% of the worst result in red as well

    Thanks

    Leave a comment:

  • Kano
    Kanotix Developer

  • Kano
    replied
    Before you complain look at the code!!! pstate is not the problem!

    Leave a comment:

  • Tares
    Senior Member

  • Tares
    replied
    Why should I modify cpufrequtils config? They are working correctly. P-state driver is the one causing issues.

    Leave a comment:

  • Kano
    Kanotix Developer

  • Kano
    replied
    @Tares
    Code:
    printf 'ENABLE="true"\nGOVERNOR="powersave"\n' > /etc/default/cpufrequtils

    Leave a comment:

  • Tares
    Senior Member

  • Tares
    replied
    So maybe Ubuntu 14.10 standard kernel doesn't like my i7-4770k with MSI Z87-GD65 mobo :/ Anyway, it's not a big issue as long as I have an alternative

    Leave a comment:

  • asavah
    Junior Member

  • asavah
    replied
    Originally posted by Tares View Post
    P-State driver doesn't work for my 4770k. Atleast not correctly. It would not scale down the frequency to the minimal values when doing nothing. I could only see ~2GHz with spikes to max speed just having terminal opened. Thanks to that temps were always higher than they should be.

    CPUFreq solved all issues. Michael, can you make investigation in this regard?
    Works fine for me.
    Kernel 3.19-rc6 with Intel p-state built-in, traditional acpi cpufreq disabled.
    Scales down to 800MHz when idle and up to 4400MHz (that's the value I set up in the UEFI for max turbo clock) when under heavy load.
    The mobo is ASUS Maximus VI Hero.

    Leave a comment:

Working...
X