No announcement yet.

Archlinux and Windows on RAID

  • Filter
  • Time
  • Show
Clear All
new posts

  • Archlinux and Windows on RAID

    I tried to install Arch on to my new desktop, together with Windows7, I should add I`ve done it on the RAID array +1 SSD disk and installed GRUB2 instead of grub1.

    More precisely:
    Using fake raid I`ve created RAID 0 array of 3 500GB disks. The Windows and the / directory of linux are on other disk, SSD 60GB Patriot inferno. The /swap /usr /home /tmp are on the RAID array. Everything went well, till the point where I was supposed to do this while installing grub2:
    # sudo modprobe dm-mod
    don`t remember the error, I`ve simply ommited the step and went on, suprisingly everything went well. Rebooted the system, the grub works, checked the Arch linux- not working. Error while checking Filesystems. The error:

    fsck.ext4: No such file or directory while trying to open /dev/sda3 Possibly non existent device?
    ************** FILESYSTEM CHECK FAILED ***************
    Please repair manually and reboot. Note that the root file
    system is currently mountes read-only. To remount it 
    read-write type: mount -n -o remount,rw / When you exit
    the maintence shell the system will reboot automatically.
    Okay I thought, I`ll se to that later, first check if windows works. I run windows- once again some error, but I knew It could happen as I was not sure of the path I`ve given to the grub. I changed it, and everything went well. Okay I think, time to check the archlinux and see how I can fix the error. I run it and.... everything goes just fine? Wut? Well, I`m happy with that. I change root password and reboot system to create new partition for windows on unallocated space on RAID matrix. Reboot, back to arch (wanted to install GPU). The system halts at "::Starting udev". After 5min I get bored, reboot. Try to launch arch- but once again the error I had at the very beginning (Filesystem check failed). And again.

    Additional info about hardware:
    Motherboard Asus M4A87TD EVO
    3x 500GB HDD working on fake RAID 0
    1x SSD 60GB

    About partitions:
    Just a note- Windows sees all partitions (including linux ones)
    /dev/sda1 windows
    /dev/sda2 windows
    /dev/sda3 linux root directory

    /dev/mapper/pdc_dbfejaidd1 swap
    /dev/mapper/pdc_dbfejaidd5 usr
    /dev/mapper/pdc_dbfejaidd6 tmp
    /dev/mapper/pdc_dbfejaidd3 home
    all linux partitions should be ext4 (it`s possible i`ve pressed accidentally and selected other partition but well, chances are small)

    the grub Archlinux boot info
    setparams 'Arch Linux, with Linux vmlinuz26'
    linsmod part_msdos
    insmod ext2
    set root='(hd0,msdos3)'
    search --no-floppy --fs-uuis --set=root 34e2754d-173d-4244-b18d-8889\
    echo 'Loading Linux vmlinuz26 ...'
    linux /boot/vmlinuz26 root=/dev/disk/by-uuid/34e2754d-173d-4244-b18d\
    -8889b378cabc ro quiet
    echo 'Loading initial ramdisk ...'
    initrd /boot/kernel26.img

    Okaay so Sth happened. I rebooted the system, logged in to windows, removed the partition I added, rebooted, run linux- everythings fine. The problem is, after once again rebooting, the bios raid utility was scanning for drives longer than before, and after this arch once again didn`t want to boot. This time it simply halts at waiting for UDev events to be processed (while BUSY).
    Then, The great return of "Filesystem Check Failed!" The only thing I did this time was launch windows and entering the partitioning tool without changing anything. No idea what`s wrong. I again rebooted the system- everything works fine... Once again reboot - Filesystem check failed. No idea what`s going on.

    I`d be grateful for any help.

  • #2
    A small change

    Now I can boot. Still I didn`t change anything, rly, I simply spent some time on Windows 7 and now everything boots okay. I think that for some reason linux might have a problem I did not create a boot partition. Can that be a problem?