I used to run VMware but it is not very convenient on Fedora - either it will not work with some new version of GCC or it won't work with some new version...