Why not, exactly? It just enables use of KDE Frameworks 5, which are extensions to Qt5....