I don't think it's a weird decision at all. RHEL 9 will get support for 10 more years, so just stick with that if you need GTK2...