Problem is compositing on many of these desktops forces Vsync, I know on KDE you can at least turn compositing off. With Wayland you can't even turn off...