All I can say is:
1) Update your motherboard BIOS, and search for a setting like this: "Typical Current Idle". Make sure you change it...