<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1978569-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1978569-1');
</script>

<script data-cfasync="false" type="text/javascript">
  var freestar = freestar || {};
  freestar.hitTime = Date.now();
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;
  freestar.config.enabled_slots = [];
  !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/phoronix-com";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
  freestar.initCallback = function () { (freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots) }
</script>
		<title>Wine 6.10 Released With Newer Mono, Updated AppData Paths - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2019">
				<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
<!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script type="text/javascript" async=true>
(function() {
  var host = 'phoronix.com';
  var element = document.createElement('script');
  var firstScript = document.getElementsByTagName('script')[0];
  var url = 'https://quantcast.mgr.consensu.org'
    .concat('/choice/', 'UEFjU_w924fg3', '/', host, '/choice.js')
  var uspTries = 0;
  var uspTriesLimit = 3;
  element.async = true;
  element.type = 'text/javascript';
  element.src = url;

  firstScript.parentNode.insertBefore(element, firstScript);

  function makeStub() {
    var TCF_LOCATOR_NAME = '__tcfapiLocator';
    var queue = [];
    var win = window;
    var cmpFrame;

    function addFrame() {
      var doc = win.document;
      var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

      if (!otherCMP) {
        if (doc.body) {
          var iframe = doc.createElement('iframe');

          iframe.style.cssText = 'display:none';
          iframe.name = TCF_LOCATOR_NAME;
          doc.body.appendChild(iframe);
        } else {
          setTimeout(addFrame, 5);
        }
      }
      return !otherCMP;
    }

    function tcfAPIHandler() {
      var gdprApplies;
      var args = arguments;

      if (!args.length) {
        return queue;
      } else if (args[0] === 'setGdprApplies') {
        if (
          args.length > 3 &&
          args[2] === 2 &&
          typeof args[3] === 'boolean'
        ) {
          gdprApplies = args[3];
          if (typeof args[2] === 'function') {
            args[2]('set', true);
          }
        }
      } else if (args[0] === 'ping') {
        var retr = {
          gdprApplies: gdprApplies,
          cmpLoaded: false,
          cmpStatus: 'stub'
        };

        if (typeof args[2] === 'function') {
          args[2](retr);
        }
      } else {
        queue.push(args);
      }
    }

    function postMessageEventHandler(event) {
      var msgIsString = typeof event.data === 'string';
      var json = {};

      try {
        if (msgIsString) {
          json = JSON.parse(event.data);
        } else {
          json = event.data;
        }
      } catch (ignore) {}

      var payload = json.__tcfapiCall;

      if (payload) {
        window.__tcfapi(
          payload.command,
          payload.version,
          function(retValue, success) {
            var returnMsg = {
              __tcfapiReturn: {
                returnValue: retValue,
                success: success,
                callId: payload.callId
              }
            };
            if (msgIsString) {
              returnMsg = JSON.stringify(returnMsg);
            }
            event.source.postMessage(returnMsg, '*');
          },
          payload.parameter
        );
      }
    }

    while (win) {
      try {
        if (win.frames[TCF_LOCATOR_NAME]) {
          cmpFrame = win;
          break;
        }
      } catch (ignore) {}

      if (win === window.top) {
        break;
      }
      win = win.parent;
    }
    if (!cmpFrame) {
      addFrame();
      win.__tcfapi = tcfAPIHandler;
      win.addEventListener('message', postMessageEventHandler, false);
    }
  };

  makeStub();

  var uspStubFunction = function() {
    var arg = arguments;
    if (typeof window.__uspapi !== uspStubFunction) {
      setTimeout(function() {
        if (typeof window.__uspapi !== 'undefined') {
          window.__uspapi.apply(window.__uspapi, arg);
        }
      }, 500);
    }
  };

  var checkIfUspIsReady = function() {
    uspTries++;
    if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
      console.warn('USP is not accessible');
    } else {
      clearInterval(uspInterval);
    }
  };

  if (typeof window.__uspapi === 'undefined') {
    window.__uspapi = uspStubFunction;
    var uspInterval = setInterval(checkIfUspIsReady, 6000);
  }
})();
</script>
<!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
    		
	</head>
	<body style="overflow: initial !important;">
		<div style="text-align: center; overflow: hidden; background: #222;"><div align="center" id="phoronix_desktop_leaderboard_header">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_desktop_leaderboard_header", slotId: "phoronix_desktop_leaderboard_header" });
  </script>
</div>
</div>		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
							<div align="center" id="phoronix_desktop_leaderboard_atf">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_desktop_leaderboard_atf", slotId: "phoronix_desktop_leaderboard_atf" });
  </script>
</div>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>Wine 6.10 Released With Newer Mono, Updated AppData Paths</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=news_topic&amp;q=WINE">WINE</a> on 4 June 2021 at 03:49 PM EDT. <a href="/forums/node/1259972">4 Comments</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="WINE -- " src="assets/categories/wine.jpg" width="100" height="100" /></div>
As another cork to pop on the <a href="https://www.phoronix.com/scan.php?page=news_item&px=Phoronix-17-This-Week">Phoronix 17th birthday</a> weekend, Wine 6.10 has been released for running Windows applications and games on Linux.<br /><br />Wine 6.10 pulls in the Mono 6.2 engine with other updates, shell folders naming scheme now follows the latest Windows updates, the WinePulse library has been converted to PE (Portable Executable) format, more math functions from Musl libc have been added to the C run-time, and there are various bug-fixes.<br /><br />Among the 25 bug fixes with Wine 6.10 are for Microsoft Office failures on start-up, fixing up the support for apps/games relying upon the user shell folder layout found in Windows Vista and later, a TrackMania Nations Forever performance regression has been fixed, and a wide range of other fixes.<br /><br />More details on all of the patches for this bi-weekly development release of Wine can be found via the 6.10 release notes on <a href="https://www.winehq.org/announce/6.10">WineHQ.org</a>.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<div align="center" id="phoronix_leaderboard_btf">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_leaderboard_btf", slotId: "phoronix_leaderboard_btf" });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1259972">4 Comments</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;">

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Wine 6.10 Released With Newer Mono, Updated AppData Paths" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=Wine-6.10-Released" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DWine-6.10-Released&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="7279734770"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div class="article-box">
								<header>Related News</header>
								<div class="node"><a href="?page=news_item&amp;px=Wine-6.9-Released">Wine 6.9 Released With More Improvements For Running Windows Apps/Games On Linux</a></div><div class="node"><a href="?page=news_item&amp;px=Wine-6.8-Released">Wine 6.8 Released With Support For Loading Libraries From Arch-Specific Subdirectories</a></div><div class="node"><a href="?page=news_item&amp;px=Wine-6.7-Released">Wine 6.7 Continues Work On Driver Plug &amp; Play, Adds ES6 JavaScript Mode</a></div><div class="node"><a href="?page=news_item&amp;px=Hangover-0.6.5-Released">Hangover 0.6.5 Released For Running Windows Software On ARM64, POWER</a></div><div class="node"><a href="?page=news_item&amp;px=Wine-6.6-Released">Wine 6.6 Released With Better Plug &amp; Play Driver Support</a></div><div class="node"><a href="?page=news_item&amp;px=Wine-Staging-6.5">Wine-Staging 6.5 Comes In A Bit Lighter Thanks To Upstreaming Many Patches</a></div>
	                             
							</div>						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<div align="center" id="phoronix_leaderboard_incontent_3">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_leaderboard_incontent_3", slotId: "phoronix_leaderboard_incontent_3" });
  </script>
</div>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 20,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="https://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Popular News This Week</header>
								<div class="node"><a href="?page=news_item&amp;px=Quake-II-RTX-Linux-Initial-Test">Quake II RTX Performance For AMD Radeon 6000 Series vs. NVIDIA On Linux</a></div><div class="node"><a href="?page=news_item&amp;px=Chrome-91-Benchmarks">Chrome 91 Benchmarks On Linux Showing Off Even Better Performance</a></div><div class="node"><a href="?page=news_item&amp;px=Firefox-89-Released">Firefox 89 Released With UI/UX Changes</a></div><div class="node"><a href="?page=news_item&amp;px=Raspberry-Pi-OS-May-2021">Raspberry Pi OS Updated With Faster OpenSSH, Software Upgrades</a></div><div class="node"><a href="?page=news_item&amp;px=AMD-NVIDIA-EO-May-2021-Drivers">NVIDIA vs. AMD Linux Gaming Performance For End Of May 2021 Drivers</a></div><div class="node"><a href="?page=news_item&amp;px=GCC-Rust-May-2021-Progress">GCC Rust Front-End Continues Advancing With Plans To Eventually Upstream</a></div><div class="node"><a href="?page=news_item&amp;px=Sailfish-OS-4.1-Released">Sailfish OS 4.1 Finally Embracing 64-bit, Android 10 App Support API Level</a></div><div class="node"><a href="?page=news_item&amp;px=KDE-Faster-NVIDIA-Wayland">KDE Plasma 5.22 Faster For NVIDIA + Wayland, More Crash Fixes</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           				<div align="center" id="phoronix_right_rail_1">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_1", slotId: "phoronix_right_rail_1" });
  </script>
</div>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=Wine-6.10-Released">Wine 6.10 Released With Newer Mono, Updated AppData Paths</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=NVIDIA-470.76-WSL-Driver">NVIDIA 470.76 WSL Driver Released</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.14-USB-Audio-Latency">Linux's USB Audio Driver Aims For Latency Reduction</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Haiku-May-2021">Haiku OS Continues Making Progress On RISC-V, Adds Stack Protection</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Wasmer-2.0-RC">Wasmer 2.0 WebAssembly Runtime Is Near With Much Faster Performance</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Atari-VCS-Controller-SDL2">Atari VCS Controller Support Added To SDL2</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Chrome-92-Beta">Chrome 92 Beta Released With File Handling API, Other Developer Additions</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-FUTEX2-System-Call-v4">FUTEX2 Linux Patches Updated To Support Variable-Sized Futexes</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=AMD-Teasing-8-June">AMD Teasing 8 June Launch Event For New Radeon Card</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=NVMe-2.0-Released">NVMe 2.0 Released  As A Library Of Specifications With ZNS, Simple Copy + More</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <div align="center" id="phoronix_right_rail_2">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_2", slotId: "phoronix_right_rail_2" });
  </script>
</div>

                        </div>
                        </aside>
			                        <aside class="widget">
                       <header>Show Your Support, Go Premium</header>
                       <p><a href="https://www.phoronix.com/scan.php?page=phoronix_premium">Phoronix Premium</a> allows ad-free access to the site, multi-page articles on a single page, and other features while supporting this site's continued operations.</p>
                        </aside>
			                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=30234">LLVM Clang 12 Leading Over GCC 11 Compiler Performance On Intel Xeon Scalable Ice Lake</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=30227">NVIDIA GeForce RTX 3080 Ti Linux Performance</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=30224">AMD Announces New Zen 3 Desktop APUs, FidelityFX Super Resolution + More</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=30218">AMD Ryzen 5 5500U - Windows 10 vs. Ubuntu 21.04 Linux Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=30217">Windows 10 vs. Ubuntu 21.04 On The AMD Ryzen Threadripper 3990X</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           				<div style="position: sticky; top: 0; position: -webkit-sticky;"><div align="center" id="phoronix_right_rail_3">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_3", slotId: "phoronix_right_rail_3" });
  </script>
</div>

</div>                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="?page=legal">Legal Disclaimer, Privacy Policy</a> | <a href="https://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2021 by <a href="https://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
		<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
	</body>
</html>
