Ubuntu PPA Updated With Mesa Git + LLVM 3.8 SVN
Written by Michael Larabel in Mesa on 13 October 2015 at 08:26 AM EDT. 11 Comments
MESA --
While Ubuntu 15.10 has Mesa 11.0 and it provides OpenGL 4 support for the Nouveau driver, it doesn't for RadeonSI. The issue is that in Ubuntu 15.10 is still an older version of LLVM that in the AMDGPU LLVM back-end lacks the needed support for OpenGL 4.0/4.1 compliance. Fortunately, a PPA has been updated for Ubuntu Wily with said support.

It's not the widely used Oibaf PPA but the paulo.miguel.dias PPA that in the past has also provided new Mesa builds against LLVM. For now this new PPA is the latest Mesa code being built against LLVM 3.8 and at the moment is just targeting Ubuntu 15.10 (Wily Werewolf). The developer behind it plans to keep this PPA updated weekly.

So if you're interested in grabbing the latest Mesa+LLVM support on Ubuntu 15.10, particularly for open-source AMD users, go see this forum thread where he's talking about his Personal Package Archive updates.
Related News
About The Author
Author picture

Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 20,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via Twitter or contacted via MichaelLarabel.com.

Popular News This Week