<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>Rust 1.23 Lowers Rustc Memory Usage - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2016">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
		<script type="text/javascript">

		  var _gaq = _gaq || [];
		  _gaq.push(['_setAccount', 'UA-1978569-1']);
		  _gaq.push(['_trackPageview']);

		  (function() {
		    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
		  })();


		    Shadowbox.init({
		       skipSetup: true
		   });
		</script>
			</head>
	<body style="overflow: initial !important;">
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://www.google.com/+phoronix" class="icon-gplus"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
						<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("180aa").style.display = 'block';
}
 }, 1000);  
  };
</script>
<strong id="180aa" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">We Rely On Your Support:</strong>  This site is primarily supported by advertisements. <span style="font-weight: 600;">Ads are what have allowed this site to be maintained for the past 14 years.</span> We do our best to ensure only clean, relevant ads are shown, when any nasty ads are detected, we work to remove them ASAP. If you would like to view the site without ads while still supporting our work, <span style="font-weight: 600;">please consider <a href="http://www.phoronix.com/scan.php?page=phoronix_premium">our ad-free Phoronix Premium</a></span>. You can also consider <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">a tip via PayPal</a>.</strong>
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[728,90]]).display();
	</script>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>Rust 1.23 Lowers Rustc Memory Usage</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=news_topic&amp;q=Free Software">Free Software</a> on 7 January 2018 at 06:56 AM EST. <a href="/forums/node/999793">10 Comments</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="FREE SOFTWARE -- " src="assets/categories/freesoftware.jpg" width="100" height="100" /></div>
For fans of Rust that didn't hear yet, Rust 1.23 was released this week as the newest stable version of this popular programming language focused on safety, speed, and concurrency.<br /><br />What we're excited about with Rust 1.23 is that the <em>rustc</em> Rust compiler should see about 5~10% lower memory usage as a result of some optimizations (avoiding unnecessary copies). Other work in Rust 1.23 includes documentation improvements, some minor improvements/stabilizations to the Rust library, and a few new Cargo features.<br /><br />Those wishing to learn more about Rust 1.23 can do so via the announcement at <a href="https://blog.rust-lang.org/2018/01/04/Rust-1.23.html">Rust-Lang.org</a>.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1506416552-3'); });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/999793">10 Comments</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;"><div style="float: left; overflow: hidden;"><div class="g-plus" data-action="share" data-annotation="bubble" data-height="15" data-href="http://www.phoronix.com/scan.php?page=news_item&amp;px=Rust-1.23-Released"></div><script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Rust 1.23 Lowers Rustc Memory Usage" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=Rust-1.23-Released" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DRust-1.23-Released&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<p align="center"><script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "728x90";
//--></script>
<script type="text/javascript" src="//tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script></p>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 10,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="http://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Related Free Software News</header>
								<div class="node"><a href="?page=news_item&amp;px=Calamares-3.2-2018-Plans">Calamares 3.2 Upgraded Linux Installer Could Be Here In March</a></div><div class="node"><a href="?page=news_item&amp;px=Git-2.16-RC0">Git 2.16 Steps Out With Its First Release Candidate</a></div><div class="node"><a href="?page=news_item&amp;px=BlueZ-5.48-Released">BlueZ 5.48 Brings New Features</a></div><div class="node"><a href="?page=news_item&amp;px=GIMP-2.10-String-Freeze">GIMP 2.10 Steps Closer To Release With String Freeze</a></div><div class="node"><a href="?page=news_item&amp;px=Darktable-2.4-Released">Darktable 2.4 Released With Many New Features, Windows Support</a></div><div class="node"><a href="?page=news_item&amp;px=Blender-2.8-Xmas-Update">Blender 2.8 Is Coming In 2018 With Huge Improvements</a></div>
	                             
							</div>
							<div class="article-box">
								<header>Popular News</header>
								<div class="node"><a href="?page=news_item&amp;px=LLVM-Clang-6.0-Features">Features To Look Forward To With LLVM / Clang 6.0</a></div><div class="node"><a href="?page=news_item&amp;px=Dell-XPS-13-2018">Dell Rolls Out New XPS 13 Laptop For 2018</a></div><div class="node"><a href="?page=news_item&amp;px=x86-PTI-Initial-Gaming-Tests">Linux Gaming Performance Doesn't Appear Affected By The x86 PTI Work</a></div><div class="node"><a href="?page=news_item&amp;px=x86-PTI-EPYC-Linux-4.15-Test">For Now At Least AMD CPUs Are Also Reported As &quot;Insecure&quot;</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-Tip-Git-Disable-x86-PTI">Linux Will End Up Disabling x86 PTI For AMD Processors - Update: Now Disabled</a></div><div class="node"><a href="?page=news_item&amp;px=systemd-2017-Git-Activity">systemd Breached One Million Lines Of Code In 2017</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-4.15-rc7-Released">Linux 4.15-rc7 Kernel Released</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=NVC0-Bindless-Texture-Kepler">Nouveau NVC0 Gallium3D Lands OpenGL Bindless Texture Support</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=OpenBenchmarking-28-Million">OpenBenchmarking.org Crosses 28,000,000 Test/Suite Benchmark Downloads</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Fedora-28-Thunderbolt-Bolt">Fedora 28 Aiming For Secure Thunderbolt 3 Support</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Rust-1.23-Released">Rust 1.23 Lowers Rustc Memory Usage</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-4.16-More-BFQ-Tuning">Linux 4.16 To Feature More BFQ Optimizations</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Solaris-11.4-GNOME-Shell">Solaris 11.4 To Move From GNOME 2 Desktop To GNOME Shell</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=RadeonSI-32-bit-GPU-Pointers">Marek Working On 32-bit GPU Pointers For RadeonSI</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Retpoline-v5-Published">Retpoline v5 Published For Fending Off Spectre Branch Target Injection</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=UBports-Unity-8-January">UBports Is Making Progress With Unity 8 On The Desktop</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "300x250,160x600,300x600";
//--></script>
<script type="text/javascript" src="https://tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=25810">DragonFlyBSD's Meltdown Fix Causing More Slowdowns Than Linux</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25807">Radeon+Ryzen CPUFreq CPU Scaling Governor Benchmarks On Linux 4.15</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25799">Docker Performance With KPTI Page Table Isolation Patches</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25791">Wine Takes Minor Performance Hit Running Windows Programs On Linux With KPTI</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25789">Linux KPTI Tests Using Linux 4.14 vs. 4.9 vs. 4.4</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           				<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-2'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6875.7_phoronix.com_tier1', [300, 600], 'div-pg-ad-1506416552-2'); });
  </script>
</div>

                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also use our <a href="http://www.tkqlhce.com/click-3677526-10515887-1435708588000">NewEgg.com</a> shopping links when making online purchases or contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="http://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="http://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="http://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                    <li><a href="https://www.google.com/+phoronix">Google Plus</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="http://www.phoronix-media.com/?k=legal">Legal Disclaimer</a> | <a href="http://www.phoronix-media.com/?k=contact">Contact</a> | <a href="?page=cookies">Cookie Policy</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2018 by <a href="http://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
					</body>
</html>
