<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>Radeon Navi 12/14 Open-Source Driver Support Now Being Marked As &quot;Experimental&quot; - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2019">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
<!-- Quantcast Choice. Consent Manager Tag -->
<script type="text/javascript" async=true>
    var elem = document.createElement('script');
    elem.src = 'https://quantcast.mgr.consensu.org/cmp.js';
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);
    (function() {
    var gdprAppliesGlobally = false;
    function addFrame() {
        if (!window.frames['__cmpLocator']) {
        if (document.body) {
            var body = document.body,
                iframe = document.createElement('iframe');
            iframe.style = 'display:none';
            iframe.name = '__cmpLocator';
            body.appendChild(iframe);
        } else {
            // In the case where this stub is located in the head,
            // this allows us to inject the iframe more quickly than
            // relying on DOMContentLoaded or other events.
            setTimeout(addFrame, 5);
        }
        }
    }
    addFrame();
    function cmpMsgHandler(event) {
        var msgIsString = typeof event.data === "string";
        var json;
        if(msgIsString) {
        json = event.data.indexOf("__cmpCall") != -1 ? JSON.parse(event.data) : {};
        } else {
        json = event.data;
        }
        if (json.__cmpCall) {
        var i = json.__cmpCall;
        window.__cmp(i.command, i.parameter, function(retValue, success) {
            var returnMsg = {"__cmpReturn": {
            "returnValue": retValue,
            "success": success,
            "callId": i.callId
            }};
            event.source.postMessage(msgIsString ?
            JSON.stringify(returnMsg) : returnMsg, '*');
        });
        }
    }
    window.__cmp = function (c) {
        var b = arguments;
        if (!b.length) {
        return __cmp.a;
        }
        else if (b[0] === 'ping') {
        b[2]({"gdprAppliesGlobally": gdprAppliesGlobally,
            "cmpLoaded": false}, true);
        } else if (c == '__cmp')
        return false;
        else {
        if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
        }
        __cmp.a.push([].slice.apply(b));
        }
    }
    window.__cmp.gdprAppliesGlobally = gdprAppliesGlobally;
    window.__cmp.msgHandler = cmpMsgHandler;
    if (window.addEventListener) {
        window.addEventListener('message', cmpMsgHandler, false);
    }
    else {
        window.attachEvent('onmessage', cmpMsgHandler);
    }
    })();
    window.__cmp('init', {
    		'Language': 'en',
		'Initial Screen Reject Button Text': 'I do not accept',
		'Initial Screen Accept Button Text': 'I accept',
		'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
		'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
		'Vendor Screen Accept All Button Text': 'Accept all',
		'Vendor Screen Reject All Button Text': 'Reject all',
		'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
		'Initial Screen Body Text Option': 1,
		'Publisher Name': 'Phoronix Media',
		'Publisher Logo': 'https://www.phoronix.com/phxcms7-css/phoronix.png',
		'Min Days Between UI Displays': 60,
		'Consent Scope': 'service',
		'UI Layout': 'banner',
		'No Option': false,
    });
</script>
<!-- End Quantcast Choice. Consent Manager Tag -->
    <style>
        .qc-cmp-button {
          background-color: #fff !important;
          border-color: #fff !important;
        }
        .qc-cmp-button:hover {
          background-color: transparent !important;
          border-color: #fff !important;
        }
        .qc-cmp-alt-action,
        .qc-cmp-link {
          color: #fff !important;
        }
        .qc-cmp-button {
          color: #222 !important;
        }
        .qc-cmp-button.qc-cmp-secondary-button {
          color: #222 !important;
        }
        .qc-cmp-button.qc-cmp-button.qc-cmp-secondary-button:hover {
          color:#ffffff !important;
        }
        .qc-cmp-button.qc-cmp-secondary-button {
          border-color: #ccc !important;
          background-color: transparent !important;
        }
        .qc-cmp-button.qc-cmp-secondary-button:hover {
          background-color: #ccc !important;
        }
        .qc-cmp-ui,
        .qc-cmp-ui .qc-cmp-main-messaging,
        .qc-cmp-ui .qc-cmp-messaging,
        .qc-cmp-ui .qc-cmp-beta-messaging,
        .qc-cmp-ui .qc-cmp-title,
        .qc-cmp-ui .qc-cmp-sub-title,
        .qc-cmp-ui .qc-cmp-purpose-info,
        .qc-cmp-ui .qc-cmp-table,
        .qc-cmp-ui .qc-cmp-table-header,
        .qc-cmp-ui .qc-cmp-vendor-list,
        .qc-cmp-ui .qc-cmp-vendor-list-title {
            color: #121212 !important;
        }
        .qc-cmp-ui a,
        .qc-cmp-ui .qc-cmp-alt-action {
          color: #444 !important;
        }
        .qc-cmp-ui {
            background-color: #348755 !important;
        }
        .qc-cmp-publisher-purposes-table .qc-cmp-table-header {
          background-color: #fafafa !important;
        }
        .qc-cmp-publisher-purposes-table .qc-cmp-table-row {
          background-color: #ffffff !important;
        }
        .qc-cmp-small-toggle.qc-cmp-toggle-on,
        .qc-cmp-toggle.qc-cmp-toggle-on {
            background-color: #666 !important;
            border-color: #666 !important;
        }
    </style>
		<!-- AA -->
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<script>
		     (adsbygoogle = window.adsbygoogle || []).push({
			  google_ad_client: "ca-pub-0253814508491313",
			  enable_page_level_ads: true
		     });
		</script>
		<!-- AA -->
		
	</head>
	<body style="overflow: initial !important;">
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[728,90]]).display();
	</script>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>Radeon Navi 12/14 Open-Source Driver Support Now Being Marked As &quot;Experimental&quot;</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=news_topic&amp;q=Radeon">Radeon</a> on 17 September 2019 at 04:46 PM EDT. <a href="/forums/node/1126690">3 Comments</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="RADEON -- " src="assets/categories/radeon.jpg" width="100" height="100" /></div>
In an interesting change of course, the open-source driver support for AMD Radeon <a href="https://www.phoronix.com/scan.php?page=search&q=Navi+12">Navi 12</a> and <a href="https://www.phoronix.com/scan.php?page=search&q=Navi+14">Navi 14</a> GPUs is being flagged as experimental and hidden behind a feature flag.
<br />
<br />Back at the start of August AMD sent out <a href="https://www.phoronix.com/scan.php?page=news_item&px=Linux-AMDGPU-Kernel-Navi-12">their AMDGPU Linux kernel driver support for Navi 12</a> along with Navi 14. That Navi 12/14 support has since been queued up for <a href="https://www.phoronix.com/scan.php?page=news_item&px=AMD-Navi-12-14-Arcturus-DRMNext">introduction in the Linux 5.4 kernel</a> along with the new Vega-based Arcturus GPU.
<br />
<br />Somewhat surprising, with the code on its way to the mainline Linux 5.4 kernel this week and already out for the past month and a half, only now the Navi 12/14 support is to be hidden behind the driver's "experimental" feature flag. In marking that support as experimental, the support isn't enabled by default but requires the <em>amdgpu.exp_hw_support=1</em> kernel module parameter to be set at boot (or driver load) time. Normally when the Intel and AMD Linux graphics drivers are hiding hardware support behind a feature flag over the preliminary state, they normally are doing so from the very beginning, not weeks later.
<br />
<br />The <a href="https://lists.freedesktop.org/archives/amd-gfx/2019-September/040100.html">patch</a> for moving Navi 12/14 as experimental for Linux 5.4 simply carries the message, "<em>We can remove this later as things get closer to launch.</em>"
<br />
<br />Presumably moving this Navi 12/14 support behind the experimental flag is being done due to bugs coming up in the driver that warrant not enabling the support by default. We have heard that <a href="https://www.phoronix.com/scan.php?page=news_item&px=Navi-14-Mesa-19.2-19.3-Git">Navi 14 is buggy with NGG</a> (Next-Gen Geometry) though it seems unlikely the kernel driver would block the support over that condition with the OpenGL/Vulkan drivers able to just use their legacy (non-NGG) path. But with Navi 12/14 being unreleased products, we're unlikely to hear anything more about the reasoning until launch.
<br />
<br />This hiding of the support behind the feature flag until "<em>closer to launch</em>" also raises the potential the Navi 12/14 introduction could be further away than some would hope. The Linux 5.4 kernel cycle just opened this past Sunday and Linux 5.4 won't be out as stable until November. AMD could always drop the experimental flag with fixes closer to launch or depending upon the changes needed to polish Navi 14/15 could end up having to wait until Linux 5.5 (entering development in November, releasing as stable in early 2020), but whatever the case we'll see how this situation plays out and cross our fingers for a smooth Navi 12/14 launch for Linux gamers and the like.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<div style="width: 50%; text-align: center; float: left;"><script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "300x250";
//--></script>
<script type="text/javascript" src="//tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script>
</div><div style="width: 50%; text-align: center; float: right;">	<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
</div>							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1126690">3 Comments</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;">

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="Radeon Navi 12/14 Open-Source Driver Support Now Being Marked As &quot;Experimental&quot;" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=Navi-12-Navi-14-AMDGPU-Exp" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DNavi-12-Navi-14-AMDGPU-Exp&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<p align="center"><script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "728x90";
//--></script>
<script type="text/javascript" src="//tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script></p>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 10,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="https://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Related Radeon News</header>
								<div class="node"><a href="?page=news_item&amp;px=RADV-NGG-StreamOut-Mesa-19.3">Radeon RADV Vulkan Driver Tackling NGG Stream-Out</a></div><div class="node"><a href="?page=news_item&amp;px=Mesa-VLK-Game-Engine-Workaround">Mesa Vulkan Drivers Now Tracking Game Engine/Version For Handling More Workarounds</a></div><div class="node"><a href="?page=news_item&amp;px=Radeon-ROCm-2.7.2-Released">Radeon ROCm 2.7.2 Released</a></div><div class="node"><a href="?page=news_item&amp;px=AMDGPU-Re-Enable-Bulk-Moves">AMDGPU Driver Looking To Re-Enable Performance-Boosting &quot;Bulk Moves&quot; Functionality</a></div><div class="node"><a href="?page=news_item&amp;px=AMD-Trusted-Memory-Zone">AMD &quot;Trusted Memory Zone&quot; Encrypted vRAM Support Coming To Their Linux GPU Driver</a></div><div class="node"><a href="?page=news_item&amp;px=AMDGPU-DC-FreeSync-LFR-Better">AMD Linux Improvements Pending Around FreeSync Low Frame Rate Compensation</a></div>
	                             
							</div>
							<div class="article-box">
								<header>Popular News This Week</header>
								<div class="node"><a href="?page=news_item&amp;px=Clear-Linux-Kernel-3s-to-300ms">How Intel's Clear Linux Team Cut The Kernel Boot Time From 3 Seconds To 300 ms</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-5.4-UMIP-Spoofing">Linux 5.4 To Fix Many Newer 64-bit Windows Games On Wine / Steam Play</a></div><div class="node"><a href="?page=news_item&amp;px=Intel-SVT-VP9-3x-AVX2-Boost">Intel's Open-Source VP9 Video Encoder Just Scored A Massive ~3x Performance Boost</a></div><div class="node"><a href="?page=news_item&amp;px=Android-Linux-Stable-Kernel-ABI">How Google's Android Maintains A Stable Linux Kernel ABI</a></div><div class="node"><a href="?page=news_item&amp;px=Microsoft-Teams-Linux">Microsoft Teams Is Coming To Linux</a></div><div class="node"><a href="?page=news_item&amp;px=GNOME-3.34-Released">GNOME 3.34 Released With Its Many Performance Improvements &amp; Better Wayland Support</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=Navi-12-Navi-14-AMDGPU-Exp">Radeon Navi 12/14 Open-Source Driver Support Now Being Marked As &quot;Experimental&quot;</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=HIPCL-CUDA-Over-OpenCL-SPIR-V">HIPCL Lets CUDA Run On OpenCL+SPIR-V</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Firefox-Four-Week-Release-Cycle">Mozilla Shifting Firefox To A Four-Week Release Cycle</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=CentOS-7.7-Released">CentOS 7.7 Released As The Last Stop Before CentOS 8.0</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Fedora-31-Beta-Released">Fedora 31 Beta Released With GNOME 3.34, Guts i686 Hardware Support</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=The-32-bit-Ubuntu-20.04-Debs">The 32-Bit Packages That Will Continue To Be Supported Through Ubuntu 20.04 LTS</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Microsoft-STL-Open-Source">Microsoft Makes Their C++ Standard Library Open-Source (STL)</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=FSF-RMS-Resigns">Richard Stallman Resigns From The Free Software Foundation</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.4-ARM-Excitement">Linux 5.4 Adds Qualcomm Snapdragon 855, Supports Some Newer ARM Laptops</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=CentOS-8.0-Next-Week">RHEL8-Based CentOS 8.0 Slated To Be Released Next Week</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Clear-Linux-Ubuntu-Eoan-Boot">A Look At The Speedy Clear Linux Boot Time Versus Ubuntu 19.10</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-1'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6874.4_phoronix.com_tier1', [300, 250], 'div-pg-ad-1506416552-1'); });
  </script>
</div>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=28257">AMD EPYC 7302 / 7402 / 7502 / 7742 Linux Performance Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=28248">Phoronix Test Suite 9.0 Released With New Result Viewer, Offline/Enterprise Benchmarking Enhancements</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=28246">Intel's Gallium3D Driver Is Running Much Faster Than Their Current OpenGL Linux Driver With Mesa 19.3</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=28238">The Sandy Bridge Core i7 3960X Benchmarked Against Today's Six-Core / 12 Thread AMD/Intel CPUs</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=28232">AMD/Intel Benchmarks: Building The Mainline Linux x86_64 Kernel With LLVM Clang</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="https://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="https://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="https://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="?page=legal">Legal Disclaimer, Privacy Policy</a> | <a href="https://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2019 by <a href="https://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
					</body>
</html>
