<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>NVIDIA Publishes Signed Volta Firmware Images For Enabling Open-Source Driver Support - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2018">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
		<!-- AA -->
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<script>
		     (adsbygoogle = window.adsbygoogle || []).push({
			  google_ad_client: "ca-pub-0253814508491313",
			  enable_page_level_ads: true
		     });
		</script>
		<!-- AA -->
			</head>
	<body style="overflow: initial !important;">
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://www.google.com/+phoronix" class="icon-gplus"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[728,90]]).display();
	</script>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("24ac").style.display = 'block';
}
 }, 1000);  
  };
</script>
<strong id="24ac" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">We Rely On Your Support:</strong>  This site is primarily supported by advertisements. <span style="font-weight: 600;">Ads are what have allowed this site to be maintained for the past 14 years.</span> We do our best to ensure only clean, relevant ads are shown, when any nasty ads are detected, we work to remove them ASAP. If you would like to view the site without ads while still supporting our work, <span style="font-weight: 600;">please consider <a href="http://www.phoronix.com/scan.php?page=phoronix_premium">our ad-free Phoronix Premium</a></span>. You can also consider <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">a tip via PayPal</a>.</strong>
<header>NVIDIA Publishes Signed Volta Firmware Images For Enabling Open-Source Driver Support</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=news_topic&amp;q=NVIDIA">NVIDIA</a> on 1 October 2018 at 01:19 PM EDT. <a href="/forums/node/1051189">15 Comments</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="NVIDIA -- " src="assets/categories/nvidia.jpg" width="100" height="100" /></div>
While there are no signs of an imminent "Turing" signed firmware release as a prerequisite for open-source driver support on the new GeForce RTX 2070/2080 series, NVIDIA has finally let loose the signed firmware images for Volta "GV100" hardware.<br /><br />Merged today to <a href="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?printer=anz&id=eb6419c26ec2872abcff15c2a6dd7030493d03bc">linux-firmware.git</a> are the signed firmware images needed for enabling Volta GV100 hardware acceleration. Since the GeForce 900 "Maxwell" series, the GPUs require signed firmware images in order to enable hardware acceleration, which has made the newer GPUs much more open-source-unfriendly than Kepler and older generations. Without these signed binary blobs, the GPUs basically only work out with Nouveau for kernel mode-setting.<br /><br />With the Linux 4.18 kernel is <a href="https://www.phoronix.com/scan.php?page=news_item&px=Nouveau-GV100-Volta-Support">initial open-source Volta support</a> albeit just the display bits with the Nouveau developers not having had these signed firmware files.<br /><p align="center"><a href="//www.phoronix.com/image-viewer.php?id=2018&image=nvidia_gv100_blobs_lrg" target="_blank"><img src="//www.phoronix.net/image.php?id=2018&image=nvidia_gv100_blobs_med" /></a></p><br />These 20 microcode/firmware files are now out there and then it will be an unknown length of time before the 3D hardware acceleration is working on Volta... It's too late to see it magically happen for Linux 4.20~5.0 so not until the next kernel cycle in 2019 is where we could possibly see that support. But even still it will likely face a similar fate to the current Maxwell/Pascal support of being very slow due to no re-clocking support to be able to change to higher performance states for reaching peak performance rather than being stuck at the low frequencies programmed at hardware initialization time.<br /><br />Long story short, if you forked over a lot of money for a Volta graphics card, your best and only real solution for the foreseeable future is using NVIDIA's proprietary but performant and feature-packed driver over any open-source option as these signed firmware files are only part of the complex equation.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1506416552-3'); });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1051189">15 Comments</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;"><div style="float: left; overflow: hidden;"><div class="g-plus" data-action="share" data-annotation="bubble" data-height="15" data-href="http://www.phoronix.com/scan.php?page=news_item&amp;px=NVIDIA-Volta-GV100-Firmware"></div><script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="NVIDIA Publishes Signed Volta Firmware Images For Enabling Open-Source Driver Support" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=NVIDIA-Volta-GV100-Firmware" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DNVIDIA-Volta-GV100-Firmware&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Phoronix Homepage -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="2439829920"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 10,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="http://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Related NVIDIA News</header>
								<div class="node"><a href="?page=news_item&amp;px=Tegra194-Queued-DRM-Next">Tegra194 &quot;Xavier&quot; Display Support Hits DRM-Next For Linux 4.20~5.0</a></div><div class="node"><a href="?page=news_item&amp;px=NVIDIA-RTX-2070-October-17">NVIDIA GeForce RTX 2070 Shipping In Three Weeks, $499+</a></div><div class="node"><a href="?page=news_item&amp;px=NVIDIA-RTX-2080-Ti-FAH-Perf"><span class="__cf_email__" data-cfemail="f7b1989b939e9990b7bf989a92">[email&#160;protected]</span> Performance Is Looking Good On The GeForce RTX 2080 Ti</a></div><div class="node"><a href="?page=news_item&amp;px=NVIDIA-Tegra-DRM-Xavier-T194">NVIDIA Sends Out DRM Display Patches For Tegra's Xavier SoC</a></div><div class="node"><a href="?page=news_item&amp;px=NVIDIA-CUDA-10-Released">NVIDIA CUDA 10 Officially Released With Turing Support, nvJPEG, CUDA-Vulkan</a></div><div class="node"><a href="?page=news_item&amp;px=Nouveau-Starts-Envy-Turing">Nouveau Developers Begin Reverse-Engineering NVIDIA Turing Driver Support</a></div>
	                             
							</div>
							<div class="article-box">
								<header>Popular News This Week</header>
								<div class="node"><a href="?page=news_item&amp;px=Libre-GPU-RISC-V-Vulkan">There's A New Libre GPU Effort Building On RISC-V, Rust, LLVM &amp; Vulkan</a></div><div class="node"><a href="?page=news_item&amp;px=Microsoft-MS-DOS-GitHub">Microsoft Launches Open-Source MS-DOS On GitHub</a></div><div class="node"><a href="?page=news_item&amp;px=Greg-KH-Linux-4.19-rc5">Greg Kroah-Hartman Releases Linux 4.19-RC5 Following An &quot;Interesting&quot; Week</a></div><div class="node"><a href="?page=news_item&amp;px=PlayOnLinux-5.0-Alpha">PlayOnLinux 5.0 Alpha Released With Redesigned UI, Phoenicis</a></div><div class="node"><a href="?page=news_item&amp;px=AMD-Platform-QoS-RFC-Patches">AMD Publishes Platform QoS Patches For Next-Gen Processors</a></div><div class="node"><a href="?page=news_item&amp;px=System76-Open-Source-Computer">System76 To Release A &quot;New Open-Source Computer&quot;</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           					<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=DAV1D-AV1-Decoder">DAV1D: A New AV1 Video Decoder From The VideoLAN Developers</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=NVIDIA-Volta-GV100-Firmware">NVIDIA Publishes Signed Volta Firmware Images For Enabling Open-Source Driver Support</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=DBus-Broker-ASG-2018">Dbus-Broker Is Still A Faster User-Space-Based D-Bus</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Nuitka-0.6-Released-Python-C">Nuitka 0.6 Released For Compiling Python Code To C</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Fedora-29-Flicker-Free-Boot">Fedora 29 Succeeds At Flicker-Free Boot Experience On Intel Hardware</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Virgl-XDC-2018">The Current Performance Of Virgl3D, Future Plans</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=September-2018-Activity"><span style="font-weight: 600;">Speck, Steam Play, RTX 2080 &amp; Linux Kernel Activity Dominated The Scene In September</span></a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-Life-Is-Strange-2-2019">Feral Is Bringing Life is Strange 2 To Linux In 2019</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Gallium-Clover-NIR-SPIR-V-XDC18">Gallium Clover With SPIR-V &amp; NIR Opening Up New Compute Options Inside Mesa</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=AMDVLK-EO-September-2018">AMDVLK Driver Gets Fixes For DXVK, New Vulkan Extensions</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-1'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6874.4_phoronix.com_tier1', [300, 250], 'div-pg-ad-1506416552-1'); });
  </script>
</div>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=26917">Additional Windows 10 vs. Ubuntu 18.04 NVIDIA/AMD Graphics Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26912">12-Way Intel / AMD Integrated Graphics Linux Tests On Ubuntu 18.10</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26905">macOS 10.14 Mojave vs. Ubuntu 18.04 LTS vs. Clear Linux Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26904">Initial Tests: Windows 10 vs. Ubuntu With NVIDIA GeForce GTX 1060 / GTX 1080 Ti / RTX 2080 Ti</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26898">AMD EPYC On Ubuntu 18.10 Putting Up A Stronger Fight Against Xeon Gold</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[160,600]]).display();
	</script>
                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also use our <a href="http://www.tkqlhce.com/click-3677526-10515887-1435708588000">NewEgg.com</a> shopping links when making online purchases or contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="http://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="http://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="http://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                    <li><a href="https://www.google.com/+phoronix">Google Plus</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="?page=legal">Legal Disclaimer, Privacy Policy</a> | <a href="http://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2018 by <a href="http://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
					</body>
</html>
