Intel's i7-5960X + X99 Motherboard On CentOS 7.0 Has Some Pains
Written by Michael Larabel in Red Hat on 3 October 2014 at 10:28 AM EDT. 6 Comments
RED HAT --
For those that may have picked up the incredibly-fast, $1000+ Intel Core i7 5960X CPU with a new required motherboard bearing the X99 chipset, be prepared for potential troubles if you're planning to install CentOS 7.0.

With the Core i7 5960X and MSI X99S SLI PLUS motherboard setup I was planning to run some CentOS 7.0 performance benchmarks from this eight-core (plus HT) benchmarks now that I've got many Ubuntu and Fedora tests under my belt for this beautiful rig. Sadly, it didn't go too far once hitting the Anaconda installer.

With this new system, the CentOS 7.0 x86_64 release didn't fully support the hardware. The USB mouse didn't work at all (for what it's worth was a ROCCAT Lua), the Gigabit Ethernet wasn't detected, and the installation process crashed for unknown reasons. The installation target was to an Intel 530 Series M.2 SSD.


Besides CentOS 7.0, this experience is likely the case with other Red Hat Enterprise Linux 7.0 derivatives too like Scientific Linux 7.0. Once I have more time to play around with EL7 on the i7-5960X + X99 (or if EL 7.1 gets released first), I'll try again to see how it goes.
About The Author
Author picture

Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 10,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via Twitter or contacted via MichaelLarabel.com.

Related Red Hat News
Popular News