<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-1978569-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-1978569-1');
</script>

<script data-cfasync="false" type="text/javascript">
  var freestar = freestar || {};
  freestar.hitTime = Date.now();
  freestar.queue = freestar.queue || [];
  freestar.config = freestar.config || {};
  freestar.debug = window.location.search.indexOf('fsdebug') === -1 ? false : true;
  freestar.config.enabled_slots = [];
  !function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/phoronix-com";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);
  freestar.initCallback = function () { (freestar.config.enabled_slots.length === 0) ? freestar.initCallbackCalled = false : freestar.newAdSlots(freestar.config.enabled_slots) }
</script>
		<title>GNOME 40's Shell Theme Code Is Rather Expensive But Optimization Pursued - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2019">
				<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
<!-- Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
<script type="text/javascript" async=true>
(function() {
  var host = 'phoronix.com';
  var element = document.createElement('script');
  var firstScript = document.getElementsByTagName('script')[0];
  var url = 'https://quantcast.mgr.consensu.org'
    .concat('/choice/', 'UEFjU_w924fg3', '/', host, '/choice.js')
  var uspTries = 0;
  var uspTriesLimit = 3;
  element.async = true;
  element.type = 'text/javascript';
  element.src = url;

  firstScript.parentNode.insertBefore(element, firstScript);

  function makeStub() {
    var TCF_LOCATOR_NAME = '__tcfapiLocator';
    var queue = [];
    var win = window;
    var cmpFrame;

    function addFrame() {
      var doc = win.document;
      var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

      if (!otherCMP) {
        if (doc.body) {
          var iframe = doc.createElement('iframe');

          iframe.style.cssText = 'display:none';
          iframe.name = TCF_LOCATOR_NAME;
          doc.body.appendChild(iframe);
        } else {
          setTimeout(addFrame, 5);
        }
      }
      return !otherCMP;
    }

    function tcfAPIHandler() {
      var gdprApplies;
      var args = arguments;

      if (!args.length) {
        return queue;
      } else if (args[0] === 'setGdprApplies') {
        if (
          args.length > 3 &&
          args[2] === 2 &&
          typeof args[3] === 'boolean'
        ) {
          gdprApplies = args[3];
          if (typeof args[2] === 'function') {
            args[2]('set', true);
          }
        }
      } else if (args[0] === 'ping') {
        var retr = {
          gdprApplies: gdprApplies,
          cmpLoaded: false,
          cmpStatus: 'stub'
        };

        if (typeof args[2] === 'function') {
          args[2](retr);
        }
      } else {
        queue.push(args);
      }
    }

    function postMessageEventHandler(event) {
      var msgIsString = typeof event.data === 'string';
      var json = {};

      try {
        if (msgIsString) {
          json = JSON.parse(event.data);
        } else {
          json = event.data;
        }
      } catch (ignore) {}

      var payload = json.__tcfapiCall;

      if (payload) {
        window.__tcfapi(
          payload.command,
          payload.version,
          function(retValue, success) {
            var returnMsg = {
              __tcfapiReturn: {
                returnValue: retValue,
                success: success,
                callId: payload.callId
              }
            };
            if (msgIsString) {
              returnMsg = JSON.stringify(returnMsg);
            }
            event.source.postMessage(returnMsg, '*');
          },
          payload.parameter
        );
      }
    }

    while (win) {
      try {
        if (win.frames[TCF_LOCATOR_NAME]) {
          cmpFrame = win;
          break;
        }
      } catch (ignore) {}

      if (win === window.top) {
        break;
      }
      win = win.parent;
    }
    if (!cmpFrame) {
      addFrame();
      win.__tcfapi = tcfAPIHandler;
      win.addEventListener('message', postMessageEventHandler, false);
    }
  };

  makeStub();

  var uspStubFunction = function() {
    var arg = arguments;
    if (typeof window.__uspapi !== uspStubFunction) {
      setTimeout(function() {
        if (typeof window.__uspapi !== 'undefined') {
          window.__uspapi.apply(window.__uspapi, arg);
        }
      }, 500);
    }
  };

  var checkIfUspIsReady = function() {
    uspTries++;
    if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
      console.warn('USP is not accessible');
    } else {
      clearInterval(uspInterval);
    }
  };

  if (typeof window.__uspapi === 'undefined') {
    window.__uspapi = uspStubFunction;
    var uspInterval = setInterval(checkIfUspIsReady, 6000);
  }
})();
</script>
<!-- End Quantcast Choice. Consent Manager Tag v2.0 (for TCF 2.0) -->
    		
	</head>
	<body style="overflow: initial !important;">
		<div style="text-align: center; overflow: hidden; background: #222;"><div align="center" id="phoronix_desktop_leaderboard_header">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_desktop_leaderboard_header", slotId: "phoronix_desktop_leaderboard_header" });
  </script>
</div>
</div>		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
							<div align="center" id="phoronix_desktop_leaderboard_atf">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_desktop_leaderboard_atf", slotId: "phoronix_desktop_leaderboard_atf" });
  </script>
</div>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("e231a9").style.display = 'block';
}
 }, 2000);  
  };
</script>
<strong id="e231a9" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">We Rely On Your Support:</strong>  This site is primarily supported by advertisements. <span style="font-weight: 600;">Ads are what have allowed this site to be maintained for the past 16 years.</span> We do our best to ensure only clean, relevant ads are shown, when any nasty ads are detected, we work to remove them ASAP. If you would like to view the site without ads while still supporting our work, <span style="font-weight: 600;">please consider <a href="https://www.phoronix.com/scan.php?page=phoronix_premium">our ad-free Phoronix Premium</a></span>. You can also consider <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">a tip via PayPal</a>.</strong>
<header>GNOME 40's Shell Theme Code Is Rather Expensive But Optimization Pursued</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=news_topic&amp;q=GNOME">GNOME</a> on 25 May 2021 at 06:13 AM EDT. <a href="/forums/node/1258180">24 Comments</a></div>
<div class="content">
<div style="float: left; padding: 0 10px 10px;"><img alt="GNOME -- " src="assets/categories/gnome.jpg" width="100" height="100" /></div>
It's been a while since last having any major/exciting optimizations to the GNOME desktop to report on by Canonical's Daniel van Vugt that is known for his performance work over the past few years, but some optimizations are forthcoming.<br /><br />In particular, Daniel noted that he noticed with GNOME 40 that up to half of the render time is being consumed by the GNOME Shell's theme code. He is now investigating possibly rewriting the slow parts of the theme code as a shader in order to cut down that render time. This work though is still in the early stages with no merge request yet or any guarantee of success.<br /><br />With Ubuntu 21.04 having stuck with GNOME 3.38 rather than using GNOME 40, there has been less exciting upstream optimizations to report on by Daniel / Ubuntu but for Ubuntu 21.10 that will presumably tick back up. It's good to see them now evaluating GNOME 40 performance shortcomings. Plus with Ubuntu 22.04 LTS now being less than one year out, we'll likely see more attention paid to ensuring GNOME's great performance for that release.<br /><br />He has also been working on other GNOME Shell optimizations, wrote a new GNOME Shell theme background optimization, started on a stencil code redesign to make that code faster, and other improvements.<br /><br />More details about some of these latest GNOME optimizations being pursued can be found via the <a href="https://discourse.ubuntu.com/t/desktop-team-updates-monday-24th-may-2021/22356/3">Ubuntu Discourse</a>.</div>
							<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<div align="center" id="phoronix_leaderboard_btf">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_leaderboard_btf", slotId: "phoronix_leaderboard_btf" });
  </script>
</div>
							</div>
							<div class="foot">
								<div class="pagination">
								</div>
								<div class="comments-label">
									<a href="/forums/node/1258180">24 Comments</a>								</div>
							</div>
						</article>
<div id="sharebar">
<div style="margin: 0 10px 10px; overflow: hidden;">

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="GNOME 40's Shell Theme Code Is Rather Expensive But Optimization Pursued" data-url="http://www.phoronix.com/scan.php?page=news_item&amp;px=GNOME-40-Expensive-Theme-Code" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Dnews_item%26amp%3Bpx%3DGNOME-40-Expensive-Theme-Code&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div></div>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-0253814508491313"
     data-ad-slot="7279734770"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div class="article-box">
								<header>Related News</header>
								<div class="node"><a href="?page=news_item&amp;px=GNOME-HIG-2021-Design">GNOME Human Interface Guidelines Being Updated For GTK4, Other Modern Features</a></div><div class="node"><a href="?page=news_item&amp;px=GNOME-41-libadwaita">GNOME 41 To Introduce Libadwaita For Helping To Define GNOME Apps</a></div><div class="node"><a href="?page=news_item&amp;px=GTK-4.2-Released">GTK 4.2 Released With NGL Renderer By Default</a></div><div class="node"><a href="?page=news_item&amp;px=GNOME-40-Released">GNOME 40 Released With Many Improvements</a></div><div class="node"><a href="?page=news_item&amp;px=GNOME-40-RC">GNOME 40 Release Candidate Arrives Ahead Of Next Week's Official Debut</a></div><div class="node"><a href="?page=news_item&amp;px=GNOME-Shell-Mutter-40-RC">The Last Minute GNOME Shell + Mutter 40 Release Candidate Changes</a></div>
	                             
							</div>						<div class="after-article">
							<div style="text-align: center; overflow: hidden; margin: 5px;">
								<div align="center" id="phoronix_leaderboard_incontent_3">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_leaderboard_incontent_3", slotId: "phoronix_leaderboard_incontent_3" });
  </script>
</div>
</div>
							<div id="about-author">
								<header>About The Author</header>
								<img class="pic" src="/assets/categories/michaellarabel.jpg" alt="Author picture"/>
								<div class="text"><p>Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 20,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via <a href="https://twitter.com/MichaelLarabel">Twitter</a> or contacted via <a href="http://www.michaellarabel.com/">MichaelLarabel.com</a>.</p></div>
							</div>
<div class="article-box">
								<header>Popular News This Week</header>
								<div class="node"><a href="?page=news_item&amp;px=Linux-5.13-UMN-Fixes">Linux 5.13 Reverts + Fixes The Problematic University of Minnesota Patches</a></div><div class="node"><a href="?page=news_item&amp;px=Big-New-Driver-Coming">Mumblings Of A &quot;Big New&quot; Open-Source GPU Driver Coming...</a></div><div class="node"><a href="?page=news_item&amp;px=Free-Software-Exits-Freenode">Free Software Projects Defenestrate The Freenode IRC Network</a></div><div class="node"><a href="?page=news_item&amp;px=Zink-Faster-May-2021">Zink OpenGL-On-Vulkan Now &quot;100%-1000% Faster&quot; For Many Scenarios</a></div><div class="node"><a href="?page=news_item&amp;px=Apple-No-More-CUPS">OpenPrinting Now Developing Upstream CUPS, Apple Bows Out</a></div><div class="node"><a href="?page=news_item&amp;px=PipeWire-0.3.28-Released">PipeWire 0.3.28 Released With More PulseAudio Modules Implemented</a></div><div class="node"><a href="?page=news_item&amp;px=SiFive-HiFive-Unmatched-Ships">SiFive HiFive Unmatched RISC-V Developer Boards Begin Shipping</a></div><div class="node"><a href="?page=news_item&amp;px=NVIDIA-470-Ends-Kepler">NVIDIA 470 Series To Be The Last Supporting GTX 600/700 Series Kepler</a></div>
							</div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           				<div align="center" id="phoronix_right_rail_1">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_1", slotId: "phoronix_right_rail_1" });
  </script>
</div>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=F2FS-RO-Read-Only">Linux 5.14 To Support F2FS Read-Only Feature</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Arm-Cortex-X2">Arm Announces The Cortex-X2 Armv9 Flagship CPU, Cortex-A710, Cortex-A510</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Intel-PXP-Off-By-Default">Intel Protected Xe Path Code Updated, Now Defaults PXP Code To Disabled</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=GNOME-40-Expensive-Theme-Code">GNOME 40's Shell Theme Code Is Rather Expensive But Optimization Pursued</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=LibreOffice-7.2-Alpha-1">LibreOffice 7.2 Alpha 1 Released For This Open-Source Office Suite</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.14-AF-XDP-Zero-Copy-IGC">Linux 5.14 To Bring Intel IGC Driver Support For AF_XDP Zero-Copy</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Inkscape-1.1-Released">Inkscape 1.1 Released With Command Palette Feature, More Export Options</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=OpenMandriva-Lx-4.3-RC">OpenMandriva Lx 4.3 RC Released With LLVM 12 Toolchain, Linux 5.12 Kernel</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=P-State-Preps-For-Hybrid">Intel P-State Driver Begins Preparing For Hybrid Processors (Alder Lake)</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Linux-5.14-DM-Optimization">Red Hat Scores A Huge DM Optimization For Linux 5.14</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Intel-AMX-Linux-Kernel-v5">Intel AMX Support Continues Being Prepped For The Linux Kernel</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Level-Zero-For-RKL-ADL-S">Intel Open-Source Stack Enables oneAPI Level Zero For Rocket Lake, Alder Lake S</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=RPi-PoE-Plus-HAT">Raspberry Pi PoE+ HAT Announced With Greater Power Capability For $20</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <div align="center" id="phoronix_right_rail_2">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_2", slotId: "phoronix_right_rail_2" });
  </script>
</div>

                        </div>
                        </aside>
			                        <aside class="widget">
                       <header>Show Your Support, Go Premium</header>
                       <p><a href="https://www.phoronix.com/scan.php?page=phoronix_premium">Phoronix Premium</a> allows ad-free access to the site, multi-page articles on a single page, and other features while supporting this site's continued operations.</p>
                        </aside>
			                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=30205">Clear Linux Offers Up Advantages For Ice Lake Xeon, CentOS Comes In Strong</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=30204">LLVM Clang 12 Compiler Is Performing Very Well For AMD Ryzen 9 5950X / Zen 3</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=30203">Ampere Is Designing Their Own Arm Server CPU Cores, Coming In 2022</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=30197">Ubuntu 20.04.2 LTS / 20.10 / 21.04 Performance On Intel Xeon Scalable Ice Lake</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=30192">GCC 11 vs. LLVM Clang 12 Performance On The Intel Core i9 11900K Is A Heated Race</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           				<div style="position: sticky; top: 0; position: -webkit-sticky;"><div align="center" id="phoronix_right_rail_3">
  <script data-cfasync="false" type="text/javascript">
      freestar.config.enabled_slots.push({ placementName: "phoronix_right_rail_3", slotId: "phoronix_right_rail_3" });
  </script>
</div>

</div>                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="?page=legal">Legal Disclaimer, Privacy Policy</a> | <a href="https://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2021 by <a href="https://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
		<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
	</body>
</html>
