Don't Expect AMDGPU To Enable SI/CIK Support By Default Anytime Soon
Written by Michael Larabel in Radeon on 7 November 2016 at 09:11 AM EST. 137 Comments
RADEON --
It seems every few days a discussion among end-users and Linux gamers re-emerge about their belief that the CIK (GCN 1.1) support any even the newer SI (GCN 1.0) support should be enabled by default in the AMDGPU kernel driver to succeed the Radeon DRM driver.

One of the most recent discussions on this matter was a mailing list thread entitled Enable AMDGPU for CIK by default. End-users are quick to jump in wanting to see the earlier AMD GCN GPU support enabled in AMDGPU for either Vulkan support, potentially greater performance, AMDGPU-PRO compatibility, etc.

As is the case everytime, AMD developers are quick to say that no default change is on the horizon. This time around it was Michel Dänzer commenting, "There are still some functional regressions, notably amdgpu doesn't support HDMI/DP audio yet. Also, simply enabling DRM_AMDGPU_CIK by default isn't a good solution, since the radeon driver also still supports the CIK devices, and there's no good mechanism to choose which driver gets to drive a particular GPU at runtime...Moreover, amdgpu doesn't work with my Kaveri laptops in my attempts so far — the panel doesn't even light up. Haven't had a chance to dig into what's happening there."

Long story short, the support isn't there entirely (DP/HDMI audio won't come to AMDGPU until the DAL code lands), there are systems in a non-working state with AMDGPU, and importantly the user-space stack needs to be new enough to support the AMDGPU kernel driver on this hardware. The Libdrm, Mesa, and xf86-video-amdgpu user-space components were only updated this year with AMDGPU support for CIK/SI and those components need to be widespread where it can be assumed they are on all major desktop deployments as to not break the stack if/when the default change is made for using AMDGPU over Radeon. It will probably be many months - if at all - before seeing the GCN 1.0/1.1 support enabled by default in AMDGPU rather than needing to spin your own kernel (or use a third-party repo, or see some distributions decide to change their default).
About The Author
Author picture

Michael Larabel is the principal author of Phoronix.com and founded the site in 2004 with a focus on enriching the Linux hardware experience. Michael has written more than 10,000 articles covering the state of Linux hardware support, Linux performance, graphics drivers, and other topics. Michael is also the lead developer of the Phoronix Test Suite, Phoromatic, and OpenBenchmarking.org automated benchmarking software. He can be followed via Twitter or contacted via MichaelLarabel.com.

Related Radeon News
Popular News This Week