<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>RADV Vulkan Gaming Getting Closer To RadeonSI OpenGL Performance - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2016">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
		<script type="text/javascript">

		  var _gaq = _gaq || [];
		  _gaq.push(['_setAccount', 'UA-1978569-1']);
		  _gaq.push(['_trackPageview']);

		  (function() {
		    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
		  })();


		    Shadowbox.init({
		       skipSetup: true
		   });
		</script>
			</head>
	<body style="overflow: initial !important;">
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://www.google.com/+phoronix" class="icon-gplus"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
										<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[728,90]]).display();
	</script>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>RADV Vulkan Gaming Getting Closer To RadeonSI OpenGL Performance</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=category&item=Linux Gaming">Linux Gaming</a> on 31 December 2017. <strong>Page 1 of 4</strong>. <a href="/forums/node/998246">8 Comments</a></div>
<div class="content">
<p>With the Mesa-based RADV Vulkan driver having just <a href="https://www.phoronix.com/vr.php?view=25745">landed a significant performance optimization</a> you may be wondering whether RADV Vulkan now leads to faster gaming frame-rates than using the mature RadeonSI OpenGL driver... I was curious so I ran some fresh benchmarks using the newest Mesa Git code.</p>
<p align="center"><a href="//www.phoronix.com/image-viewer.php?id=radv-radeonsi-close&image=radv_radeonsi_close_lrg" target="_blank"><img src="//www.phoronix.net/image.php?id=radv-radeonsi-close&image=radv_radeonsi_close_med" /></a></p>
<p>On a Radeon RX 580 and RX Vega 64 I ran fresh Mesa 17.4-dev benchmarks following the DCC improvements landing in RADV. That was built against LLVM 6.0 SVN and on the kernel side was Linux 4.15 Git.</p>
<div style="text-align: center; overflow: auto;"><script src="//openbenchmarking.org/embed.php?i=1712313-AL-MESA174DE27&sha=a398d80&p=0" type="text/javascript"></script><noscript><a href="http://openbenchmarking.org/result/1712313-AL-MESA174DE27"><img src="//openbenchmarking.org/embed.php?i=1712313-AL-MESA174DE27&sha=a398d80&p=1" /></a></noscript></div>
<p>Using Dota 2, Dawn of War 3, Mad Max, Serious Sam 3: BFE, and Talos Principle a range of OpenGL vs. Vulkan benchmarks were carried out with these being the notable Linux-native games featuring both OpenGL and Vulkan rendering support. Tests were carried out with the <a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a>.</p>
</div>
<div id="sharebar"><div style="float: left; overflow: hidden;"><div class="g-plus" data-action="share" data-annotation="bubble" data-height="15" data-href="http://www.phoronix.com/scan.php?page=article&item=radv-radeonsi-close&num=1"></div><script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="RADV Vulkan Gaming Getting Closer To RadeonSI OpenGL Performance" data-url="http://www.phoronix.com/scan.php?page=article&item=radv-radeonsi-close&num=1" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Darticle%26item%3Dradv-radeonsi-close%26num%3D1&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div>							<div style="text-align: center; overflow: hidden; margin: 10px auto 30px;">
								<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1506416552-3'); });
  </script>
</div>
<br />							</div>

<div style="margin: 0 0 10px 0;"><select id="phx_article_page_selector" onchange="javascript:document.location.href = document.getElementById('phx_article_page_selector').options[document.getElementById('phx_article_page_selector').options.selectedIndex].value;"><option value="?page=article&amp;item=radv-radeonsi-close&amp;num=1" selected="selected">Page 1 - Introduction</option><option value="?page=article&amp;item=radv-radeonsi-close&amp;num=2">Page 2 - Dota 2 + Dawn of War 3</option><option value="?page=article&amp;item=radv-radeonsi-close&amp;num=3">Page 3 - Mad Max</option><option value="?page=article&amp;item=radv-radeonsi-close&amp;num=4">Page 4 - Serious Sam 3 + Talos Principle</option></select></div>
					<div class="foot">
								<div class="pagination">
Page: <span>1</span><a href="?page=article&amp;item=radv-radeonsi-close&amp;num=2">2</a><a href="?page=article&amp;item=radv-radeonsi-close&amp;num=3">3</a><a href="?page=article&amp;item=radv-radeonsi-close&amp;num=4">4</a><a href="?page=article&amp;item=radv-radeonsi-close&amp;num=2" title="Go To Next Page">Next Page</a>								</div>
								<div class="comments-label">
									<a href="/forums/node/998246">8 Comments</a>								</div>
							</div>
						</article>
						<div class="after-article">
<div style="text-align: center; overflow: hidden; margin-bottom: 20px;"><script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1506416552-3'); });
  </script>
</div>
</div><br /><div class="article-box">
								<header>Related Articles</header>
								<div class="node"><a href="/vr.php?view=25718">OpenGL vs. Vulkan Linux Gaming Performance Ending Out 2017</a></div><div class="node"><a href="/vr.php?view=25685">SteamVR On Linux Is Still In Frustratingly Rough Shape</a></div><div class="node"><a href="/vr.php?view=25677">AMD FreeSync For Tear-Free Linux Gaming - Current State In 2017</a></div><div class="node"><a href="/vr.php?view=25556">The Impact Of HDD/SSD Performance On Linux Gaming</a></div><div class="node"><a href="/vr.php?view=25544">Intel's Mesa GLSL Shader Cache Is Speeding Up Game Load Times</a></div>
	                             
							</div>
							<div class="article-box"><header>Trending Linux News</header><div class="node"><a href="?page=news_item&amp;px=Ubuntu-Monthly-Proposal-WIP">A Proposal To Update Ubuntu's Kernel/Mesa/GNOME Components On A Monthly Basis</a></div><div class="node"><a href="?page=news_item&amp;px=Syzbot-Linux-Kernel-Fuzzing">Syzbot: Google Continuously Fuzzing The Linux Kernel</a></div><div class="node"><a href="?page=news_item&amp;px=RAID-1-10-Balance-Patch">Btrfs Gets A RAID1/10 Speed Patch, Helping Out SSDs</a></div><div class="node"><a href="?page=news_item&amp;px=NetBSD-7.1.1-Released">NetBSD 7.1.1 Released</a></div><div class="node"><a href="?page=news_item&amp;px=Jailhouse-0.8-Hypervisor">Jailhouse v0.8 Linux Hypervisor Released</a></div></div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=Mesa-17.2.2-17.3.1-17.4-RSI">Mesa 17.2.2 vs. 17.3.1 vs. 17.4-dev RadeonSI Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=AMDGPU-PRO-Hack-Clover">AMDGPU-PRO OpenCL Compiler Hacked Into Mesa's Clover</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Haiku-OS-EOY-2017">Haiku OS Ends 2017 On A High Note With Better USB 3.0 &amp; UEFI Abilities</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Nouveau-2017">Nouveau Persevered In 2017 For Open-Source NVIDIA But 2018 Could Be Much Better</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=RADV-Vega-Binning">RADV Driver Lands Support For Binning With Vega</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=LLVM-Clang-6.0-Features">Features To Look Forward To With LLVM / Clang 6.0</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=AMDGPU-Last-For-Linux-4.16">AMDGPU Gets Its Last Feature Updates For Linux 4.16</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Arcan-0.5.4-Durden-0.4">Arcan 0.5.4 Display Server Released With Durden 0.4 Desktop</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Happy-New-Year-For-2018"><span style="font-weight: 600;">Happy New Year's From Phoronix &amp; Here's To An Awesome 2018</span></a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Glade-3.21-Released">Glade 3.21 Released For Whipping Up GTK3 Interfaces</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "300x250,160x600,300x600";
//--></script>
<script type="text/javascript" src="https://tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=25754">RADV Vulkan Gaming Getting Closer To RadeonSI OpenGL Performance</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25747">KVM Smokes VirtualBox On Initial AMD EPYC Linux Tests</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25745">RADV Vulkan Driver Ends The Year On A High Note With A Performance Boost</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25744">How Linux Performance Changed In 2017 With Clear Linux &amp; Ubuntu</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=25742">GCC 8 vs. LLVM Clang 6 Performance At End Of Year 2017</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           				<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-2'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6875.7_phoronix.com_tier1', [300, 600], 'div-pg-ad-1506416552-2'); });
  </script>
</div>

                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also use our <a href="http://www.tkqlhce.com/click-3677526-10515887-1435708588000">NewEgg.com</a> shopping links when making online purchases or contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="http://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="http://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="http://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                    <li><a href="https://www.google.com/+phoronix">Google Plus</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="http://www.phoronix-media.com/?k=legal">Legal Disclaimer</a> | <a href="http://www.phoronix-media.com/?k=contact">Contact</a> | <a href="?page=cookies">Cookie Policy</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2017 by <a href="http://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
					</body>
</html>
