<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
	<head>
		<title>GCC 8.1 vs. GCC 7.3 Compiler Benchmarks On Five AMD/Intel Linux Systems - Phoronix</title>
		<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
		<link rel="stylesheet" href="phxcms-css/phoronix-10.css?2018">
		<meta name="viewport" content="width=device-width, initial-scale=1.0">
		<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js"></script>
		<link href="phxcms7-css/shadowbox.css" rel="stylesheet" type="text/css" />
		<script src="phxcms7-css/shadowbox.js" type="text/javascript"></script>
		<meta name="keywords" content="Phoronix, Linux Hardware Reviews, Linux hardware benchmarks, Linux Hardware, Linux benchmarking, Desktop Linux, GNU/Linux benchmarks, Open Source AMD, Linux How To, X.Org drivers, Ubuntu hardware, Phoronix Test Suite" />
		<meta name="Description" content="Phoronix is the leading technology website for Linux hardware reviews, open-source news, Linux benchmarks, open-source benchmarks, and computer hardware tests." />
		<link rel="alternate" type="application/rss+xml" title="Phoronix" href="rss.php" />
		<link rel="shortcut icon" href="favicon.ico" />
		<link rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" />
		<link rel="apple-touch-icon" sizes="60x60" href="/apple-touch-icon-60x60.png" />
		<link rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" />
		<link rel="apple-touch-icon" sizes="76x76" href="/apple-touch-icon-76x76.png" />
		<link rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" />
		<link rel="apple-touch-icon" sizes="120x120" href="/apple-touch-icon-120x120.png" />
		<link rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" />
		<link rel="apple-touch-icon" sizes="152x152" href="/apple-touch-icon-152x152.png" />
		<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon-180x180.png" />
		<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32" />
		<link rel="icon" type="image/png" href="/android-chrome-192x192.png" sizes="192x192" />
		<link rel="icon" type="image/png" href="/favicon-96x96.png" sizes="96x96" />
		<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16" />
		<meta name="msapplication-TileImage" content="/mstile-144x144.png" />
				<!-- PHXCMS-11 (phoronix.com) -->
		<!-- AA -->
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<script>
		     (adsbygoogle = window.adsbygoogle || []).push({
			  google_ad_client: "ca-pub-0253814508491313",
			  enable_page_level_ads: true
		     });
		</script>
		<!-- AA -->
			</head>
	<body style="overflow: initial !important;">
		<div id="headerwrap">
			<div class="wcontainer defpadding">
				<a href="?page=home"><img id="logo" alt="Phoronix" src="/phxcms7-css/phoronix.png" style="height: 40px; margin-top: 5px;margin-left: 5px;" /></a>
				<div id="headerright">
					<div id="social">
					    <a href="https://www.phoronix.com/rss.php" class="icon-rss"></a>
					    <a href="https://www.google.com/+phoronix" class="icon-gplus"></a>
					    <a href="https://twitter.com/Phoronix" class="icon-twitter"></a>
					    <a href="https://www.facebook.com/Phoronix" class="icon-facebook"></a>
					</div>
				</div>
			</div>
		</div>
		<div id="litemenu">
		    <ul>
		        <li><a href="?page=phoronix_articles">Articles &amp; Reviews</a></li>
		        <li><a href="?page=phoronix_news">News Archive</a></li>
		        <li><a href="https://www.phoronix.com/forums/">Forums</a></li>
		        <li><a href="?page=phoronix_premium">Premium</a></li>		        <li class="categ icon-angle-circled-down"><span> Categories</span></li>
		        <li><a href="?page=category&amp;item=Computers">Computers</a></li>
				<li><a href="?page=category&amp;item=Display+Drivers">Display Drivers</a></li>
				<li><a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a></li>
				<li><a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a></li>
				<li><a href="?page=category&amp;item=Memory">Memory</a></li>
				<li><a href="?page=category&amp;item=Motherboards">Motherboards</a></li>
				<li><a href="?page=category&amp;item=Processors">CPUs / Processors</a></li>
				<li><a href="?page=category&amp;item=Software">Software</a></li>
				<li><a href="?page=category&amp;item=Storage">Storage</a></li>
				<li><a href="?page=category&amp;item=Operating+Systems">Operating Systems</a></li>
				<li><a href="?page=category&amp;item=Peripherals">Peripherals</a></li>
				<li id="closelid">Close</li>
		    </ul>		    
		</div>
		<div id="menuwrap">
			<div class="wcontainer">
				<ul id="linklist">
					<li id="menubutton"><span class="icon-menu"></span>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_articles">Articles &amp; Reviews</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_news">News Archive</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="https://www.phoronix.com/forums/">Forums</a>
					</li>
					<li class="menulink">
						<a class="linknode" href="?page=phoronix_premium">Premium</a>
					</li>					<li id="categories-link" class="menulink">
						<span class="menunolink icon-angle-circled-down"> Categories</span>
						<div id="categories-list">
							<div id="categories-content">
								<a href="?page=category&amp;item=Computers">Computers</a>
								<a href="?page=category&amp;item=Graphics+Cards">GPUs / Graphics Cards</a>
								<a href="?page=category&amp;item=Linux+Gaming">Linux Gaming</a>
								<a href="?page=category&amp;item=Memory">Memory</a>
								<a href="?page=category&amp;item=Motherboards">Motherboards</a>
								<a href="?page=category&amp;item=Processors">CPUs / Processors</a>
								<a href="?page=category&amp;item=Software">Software</a>
								<a href="?page=category&amp;item=Storage">Storage</a>
								<a href="?page=category&amp;item=Operating+Systems">Operating Systems</a>
								<a href="?page=category&amp;item=Peripherals">Peripherals</a>
							</div>
						</div>
					</li>
					<li id="searchbox">
						<div id="search">
							<form action="https://www.google.com" id="cse-search-box" target="_blank">
							  <div>
							    <input type="hidden" name="cx" value="partner-pub-0253814508491313:1305299758" />
							    <input type="hidden" name="ie" value="UTF-8" />
							    <input type="text" name="q" />
							    <input type="submit" name="sa" value="Search" />
							  </div>
							</form>

							<script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>
						</div>
					</li>
				</ul>
			</div>
		</div>
		<div id="content-bg">
			<div id="content">
						<script type="text/javascript">
  window.onload = function() {
    setTimeout(function() {
if(typeof aax_getad_mpb === 'undefined') 
{
	document.getElementById("247f631").style.display = 'block';
}
 }, 1000);  
  };
</script>
<strong id="247f631" style="display: none; border: 1px solid #efefef; font-size: 11.5px; margin: 9px;"><strong style="font-weight: 800;">We Rely On Your Support:</strong>  This site is primarily supported by advertisements. <span style="font-weight: 600;">Ads are what have allowed this site to be maintained for the past 14 years.</span> We do our best to ensure only clean, relevant ads are shown, when any nasty ads are detected, we work to remove them ASAP. If you would like to view the site without ads while still supporting our work, <span style="font-weight: 600;">please consider <a href="http://www.phoronix.com/scan.php?page=phoronix_premium">our ad-free Phoronix Premium</a></span>. You can also consider <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">a tip via PayPal</a>.</strong>
				<div id="main-wrap">
					<div id="main">
						<div style="text-align: center; overflow: hidden; margin-bottom: 30px;">
								<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[728,90]]).display();
	</script>

						</div>
						<!-- google_ad_section_start -->
<article class="full">
<header>GCC 8.1 vs. GCC 7.3 Compiler Benchmarks On Five AMD/Intel Linux Systems</header>
<div class="author">Written by <a href="?page=michaellarabel">Michael Larabel</a> in <a href="?page=category&item=Software">Software</a> on 10 May 2018. <strong>Page 1 of 6</strong>. <a href="/forums/node/1023975">7 Comments</a></div>
<div class="content">
<p>With <a href="https://www.phoronix.com/scan.php?page=search&q=GCC+8.1">GCC 8.1</a> having been officially released last week, I have spent the past number of days running a variety of compiler benchmarks comparing this initial GCC8 stable release to the previous GCC 7.3 stable compiler release. Tests were done on five different Ubuntu 18.04 LTS Linux systems running very different AMD and Intel processors.</p>
<p align="center"><a href="//www.phoronix.com/image-viewer.php?id=gcc-81-benchmarks&image=gcc_81_compiler_lrg" target="_blank"><img src="//www.phoronix.net/image.php?id=gcc-81-benchmarks&image=gcc_81_compiler_med" /></a></p>
<p>This GCC 8.1 vs. GCC 7.3 compiler benchmark comparison was done when building both out-of-the-box in the same manner (simply with --enable-checking=release --disable-multilib) and then using the respective compiler on each of the systems for compiling the benchmarks and running these test profiles via the <a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a>. During the benchmarking process and while the test profiles were being installed with the compiler under test, the CFLAGS/CXXFLAGS on each of the systems were set to "-O3 -march=native" for doing an optimized build comparison.</p>
<p>All five systems were running Ubuntu 18.04 LTS x86_64, but that's about as much as was in common with these five distinct systems used for getting an overall view at the direction of the GCC 8 performance. The test systems came down to:</p>
<p><strong>Core i7 8700K</strong> - The current-generation i7-8700K Coffeelake CPU that is six cores / 12 threads and the system was built with the ASUS PRIME Z370-A motherboard, 16GB of DDR4, 120GB Intel SSD, and Radeon RX Vega 64 graphics card.</p>
<p><strong>Core i9 7980XE</strong> - The high-end Skylake-X system with 18 cores / 36 threads, ASUS PRIME X299-A motherboard, 16GB DDR4, and Intel 256GB 700p SSD.</p>
<p><strong>2 x Xeon Gold 6138</strong> - The Tyan 1U server with two Xeon Gold 6138 Xeon Scalable CPUs for delivering 40 cores / 80 threads with 96GB of RAM, and 256GB Samsung 850 SSD.</p>
<p><strong>Ryzen 7 2700X</strong> - The new high-end Zen+ CPU with eight cores / 16 threads. This system had the ASUS ROG CROSSHAIR VII HERO motherboard, 8GB DDR4, Samsung 950 PRO 256GB SSD, and Radeon RX 580 graphics card.</p>
<p><strong>EPYC 7601</strong> - The AMD EPYC 7601 CPU with 32 cores / 64 threads in a single-socket configuration on a Tyan 2U server with 128GB of DDR4 memory and 280GB Intel 900p SSD.</p>
<p>A variety of C/C++ benchmarks were carried out on all five systems with both GCC 7.3 and GCC 8.1 using the <a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a>. See our <a href="https://www.phoronix.com/scan.php?page=news_item&px=GCC-8-Compiler-Features-List">GCC 8.1 feature overview</a> to learn about the changes in this </p>
</div>
<div id="sharebar"><div style="float: left; overflow: hidden;"><div class="g-plus" data-action="share" data-annotation="bubble" data-height="15" data-href="http://www.phoronix.com/scan.php?page=article&item=gcc-81-benchmarks&num=1"></div><script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script></div>

<div style="float: left; overflow: hidden;"><a href="https://twitter.com/share" class="twitter-share-button" data-text="GCC 8.1 vs. GCC 7.3 Compiler Benchmarks On Five AMD/Intel Linux Systems" data-url="http://www.phoronix.com/scan.php?page=article&item=gcc-81-benchmarks&num=1" data-via="phoronix" data-related="michaellarabel">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>

<div style="float: left; overflow: hidden;"><iframe src="//www.facebook.com/plugins/like.php?href=http://www.phoronix.com/scan.php%3Fpage%3Darticle%26item%3Dgcc-81-benchmarks%26num%3D1&amp;width=200&amp;height=46&amp;colorscheme=light&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;send=true" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:200px; height:46px;" allowTransparency="true"></iframe></div>
</div>							<div style="text-align: center; overflow: hidden; margin: 10px auto 30px;">
								<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1506416552-3'); });
  </script>
</div>
<br />							</div>

<div style="margin: 0 0 10px 0;"><select id="phx_article_page_selector" onchange="javascript:document.location.href = document.getElementById('phx_article_page_selector').options[document.getElementById('phx_article_page_selector').options.selectedIndex].value;"><option value="?page=article&amp;item=gcc-81-benchmarks&amp;num=1" selected="selected">Page 1 - Introduction</option><option value="?page=article&amp;item=gcc-81-benchmarks&amp;num=2">Page 2 - GCC 8 Benchmarks</option><option value="?page=article&amp;item=gcc-81-benchmarks&amp;num=3">Page 3 - GCC 8 Benchmarks</option><option value="?page=article&amp;item=gcc-81-benchmarks&amp;num=4">Page 4 - GCC 8 Benchmarks</option><option value="?page=article&amp;item=gcc-81-benchmarks&amp;num=5">Page 5 - GCC 8 Benchmarks</option><option value="?page=article&amp;item=gcc-81-benchmarks&amp;num=6">Page 6 - GCC 8 Benchmarks</option></select></div>
					<div class="foot">
								<div class="pagination">
Page: <span>1</span><a href="?page=article&amp;item=gcc-81-benchmarks&amp;num=2">2</a><a href="?page=article&amp;item=gcc-81-benchmarks&amp;num=3">3</a><a href="?page=article&amp;item=gcc-81-benchmarks&amp;num=4">4</a><a href="?page=article&amp;item=gcc-81-benchmarks&amp;num=5">5</a><a href="?page=article&amp;item=gcc-81-benchmarks&amp;num=6">6</a><a href="?page=article&amp;item=gcc-81-benchmarks&amp;num=2" title="Go To Next Page">Next Page</a>								</div>
								<div class="comments-label">
									<a href="/forums/node/1023975">7 Comments</a>								</div>
							</div>
						</article>
						<div class="after-article">
<div style="text-align: center; overflow: hidden; margin-bottom: 20px;"><script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<div id='div-pg-ad-1506416552-3'>
  <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.pubads().display('/8095840/.2_6876.3_phoronix.com_tier1', [728, 90], 'div-pg-ad-1506416552-3'); });
  </script>
</div>
</div><br /><div class="article-box">
								<header>Related Articles</header>
								<div class="node"><a href="/vr.php?view=26206">Linux 4.17 Offers Some Promising Power-Savings Improvements</a></div><div class="node"><a href="/vr.php?view=26201">The Many Great Features &amp; Changes Coming For The Linux 4.17 Kernel</a></div><div class="node"><a href="/vr.php?view=26158">Linux 4.4 To 4.16 Kernel Benchmarks With AMD Ryzen Threadripper</a></div><div class="node"><a href="/vr.php?view=26150">Linux 3.17 To Linux 4.16 Kernel Benchmarks On Intel Gulftown &amp; Haswell Hardware</a></div><div class="node"><a href="/vr.php?view=26108">LLVM Clang 6.0 vs. 5.0 Compiler Performance On Intel/AMD Linux</a></div>
	                             
							</div>
							<div class="article-box"><header>Trending Linux News</header><div class="node"><a href="?page=news_item&amp;px=Vulkan-Ray-Tracing-NVIDIA">NVIDIA's Work On Adding Ray-Tracing To Vulkan</a></div><div class="node"><a href="?page=news_item&amp;px=FreeDesktop-GitLab-Migration">FreeDesktop.org Migrating To GitLab</a></div><div class="node"><a href="?page=news_item&amp;px=Mark-Shuttleworth-Ubiquity-NG">Mark Shuttleworth Talks Of New Ubuntu Installer Ideas With HTML5/Electron &amp; Snaps</a></div><div class="node"><a href="?page=news_item&amp;px=LLVM-Strip">LLVM-Strip Introduced As An Alternative To GNU Strip</a></div><div class="node"><a href="?page=news_item&amp;px=Linux-4.17-rc4-Released">Linux 4.17-rc4 Released As The &quot;Merciless Moray&quot;</a></div></div>		</div>
<!-- google_ad_section_end -->
					</div>
				</div>
				<div id="sidebar-wrap">
					<div id="sidebar">
					    <aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[300,250]]).display();
	</script>
                        </div>
                        </aside>
                        <aside class="widget">
			<header>Latest Linux News</header><div class="popular-list">
                                <a href="?page=news_item&amp;px=Rust-1.26-Released">Rust 1.26 Continues With Speed Improvements, Adds Support For 128-Bit Integers</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=X.Org-Server-1.20-Released">X.Org Server 1.20 &quot;Avocado Toast&quot; Released With DRI3 v1.2, VR Improvements</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Clear-GCC-8.1-Rollout">Intel's Clear Linux Moving For A Quick Rollout Of GCC 8</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=CentOS-7-1804-Released">CentOS 7 1804 Released As The Free Spin Of RHEL 7.5</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Ubuntu-i386-Dropping-Discussion">Ubuntu Developers Once Again Debate Dropping i386 Images, Then Discontinuing i386 Port</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=VIA-Edge-AI-Developer-Kit">VIA Joins In The AI Race, Linux/Android Support For Their New Developer Kit</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=AMDVLK-9-May-Update">AMDVLK Vulkan Driver Sees A Big Update, Prepping For VK_EXT_descriptor_indexing</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=CodeSourcery-AMD-GCN">CodeSourcery Has Ported OpenMP / OpenACC To AMD GCN GPUs With GCC</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Xorg-Server-Pointer-Accel">Understanding The X.Org Server's Complex Pointer Acceleration Code</a>
                            </div>
<div class="popular-list">
                                <a href="?page=news_item&amp;px=Debuan-2.0-RC-Released">Devuan 2.0 As Debian Without Systemd Hits Release Candidate Stage</a>
                            </div>
                        </aside>
			<aside>
			<div style="text-align: center;">
                          <script type="text/javascript"><!--
	e9 = new Object();
    e9.size = "300x250,160x600,300x600";
//--></script>
<script type="text/javascript" src="https://tags.expo9.exponential.com/tags/Phoronixcom/ROS/tags.js"></script>
                        </div>
                        </aside>

                        <aside class="widget">
			<header>Latest Featured Articles</header><div class="popular-list">
                                <a href="/vr.php?view=26276">GCC 8.1 vs. GCC 7.3 Compiler Benchmarks On Five AMD/Intel Linux Systems</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26270">RADV vs. AMDGPU-PRO vs. AMDVLK Vulkan Linux Driver Performance</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26262">Ubuntu 18.04 LTS vs. Fedora 28 vs. Clear Linux Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26258">Radeon Software 18.10 vs. Mesa 18.2 RADV/RadeonSI Benchmarks</a>
                            </div>
<div class="popular-list">
                                <a href="/vr.php?view=26251">Ubuntu 16.04 vs. 18.04 Performance On Six Systems</a>
                            </div>
                        </aside>
			<aside>
						<div style="text-align: center;">
                           					<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js'>
		googletag.pubads().definePassback('8456/IDG.Phoronix.com_Homepage', [[160,600]]).display();
	</script>
                       				 </div>
                        </aside>
                        <aside class="widget">
                            <header>Support Phoronix</header>
                            <p>The mission at Phoronix since 2004 has centered around enriching the Linux hardware experience. In addition to supporting our site through advertisements, you can help by <a href="?page=phoronix_premium">subscribing to Phoronix Premium</a>. You can also use our <a href="http://www.tkqlhce.com/click-3677526-10515887-1435708588000">NewEgg.com</a> shopping links when making online purchases or contribute to Phoronix through a <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=3778540">PayPal tip</a>.</p>
                        </aside>
					</div>
				</div>
			</div>
		</div>
		<div id="footer">
		    <div id="footer-content">
			<p align="center"></p>
		        <div id="footer-left">
		        <div id="footer-left-content">
		            <div class="extra-info">
		                <header>Phoronix Media</header>
		                <hr/>
		                <ul>
		                    <li><a href="http://www.phoronix-test-suite.com/">Phoronix Test Suite</a></li>
		                    <li><a href="http://openbenchmarking.org/">OpenBenchmarking.org</a></li>
		                    <li><a href="http://www.phoromatic.com/">Phoromatic</a></li>
		                    <li><a href="http://www.linuxbenchmarking.com/">LinuxBenchmarking.com</a></li>
		                </ul>
		            </div>
		            <div class="extra-info">
		                <header>Phoronix Premium</header>
		                <hr/>
		                <a href="?page=phoronix_premium"><ul>
                            <li>Support Phoronix</li>
		                    <li>While Having Ad-Free Browsing,</li>
                            <li>Single-Page Article Viewing</li>
                        </ul></a>
		            </div>
		            <div class="extra-info">
		                <header>Share</header>
		                <hr/>
		                <ul>
		                    <li><a href="https://facebook.com/Phoronix">Facebook</a></li>
		                    <li><a href="https://twitter.com/Phoronix">Twitter</a></li>
		                    <li><a href="https://www.google.com/+phoronix">Google Plus</a></li>
		                </ul>
		            </div>
		       </div>
		       </div>
		       <div id="footer-right">
		            <div class="extra-info">
		                <ul>
		                <li><p><a href="?page=legal">Legal Disclaimer, Privacy Policy</a> | <a href="http://www.phoronix-media.com/?k=contact">Contact</a></p></li>
                        <li><p>Copyright &copy; 2004 - 2018 by <a href="http://www.phoronix-media.com/">Phoronix Media</a>.</p></li>
                        <li><p>All trademarks used are properties of their respective owners. All rights reserved.</p></li>
				</ul>
		            </div>
		        </div>
		     </div>		   
		</div>
				<script type="text/javascript">
		    function lmm () {
		        if (litemenu.style.zIndex > 0)
		            litemenu.style.zIndex = -1;
		        else
		            litemenu.style.zIndex = 1;
		    }
		    	    
            menubutton.addEventListener('click', function() { lmm(); }, false);
            closelid.addEventListener('click', function() { litemenu.style.zIndex = -1;}, false);
		</script>
					</body>
</html>
