I tried it on OpenSUSE Leap 15 (latest RC) and it failed miserably. I did sent them a note. Granted, it's not released, but still.