It's hardly the latest, C++11 was well supported in GCC 4.8, released 4 years ago. It was mostly there much earlier. Even Microsoft's 2015 compiler supports...