Sounds like this is not really about security updates or protecting users from blocked (by which provider ?) updates....