Isn't the original license also incompatible with the GPLv2? At least this new one adds GPLv3 compatibility....