They are just fine. If they aren't, it means that your distribution has built LibreOffice without kdelibs4-support, which still exists and properly integrates...