Try the 2.49a version with Qt 5 and Frameworks 5.

I don't have any Qt 4 program, but many programs still using deprecated KDE 4 classes (ported...