If they object to ASL2, they can always choose to hoist themselves on their own petard and keep using the latest non-ASL2 release of LLVM, just like they...