I hope it will be easily installable on distros other than Ubuntu LTS.