oh... even with gcc6 we have problems https://bugs.gentoo.org/show_bug.cgi?id=gcc-6 it means you can use only one compiler....