On modern versions of Ubuntu (16.04+), you should be able to just apt install the 32-bit gstreamer libraries by appending :i386 to the end of their package...