It sucks that it requires the KDE framework I would appreciate a Qt5 version.