All this incompatibility between Python2 and Python3, for no apparent reason making me tired of Python. Trying to support packages for both 2 and 3 is...