Yes it does work on 4.9.

Stable enough but I would not use that except if you want to use or test vulkan....