Re VirtualBox, disable automatic keyboard capture in the global settings....