Mozilla is dropping support for CPUs without SSE2, that's Pentium 3 and Athlon XP or older, those are over 15 years old and makes developing difficult...