This maybe your opensource radv vulkan performance fix: Solution--reconfigure kernel: "make menuconfig"/Bus options/PCI support/PCI Express...