FWIW I just updated Manjaro/KDE with the kde-git package repo and this 5.18.80 beta just arrived...

[packages]
SigLevel = Optional...