i think that is because there are various legacy linux setups that might be too much of a hassle to provide support for.

not everybody needs...