I thought about it too, but the problem seems to be that /e/ requires Android 10 and Ubuntu Touch requires Android 9 baseband support....