They need only the linux-_headers_, which are often in an extra package, but sometimes only in the sources-package.
Btw, the first NT was NT 3.1....