Announcement

Collapse
No announcement yet.

KDevelop 5.0 Appears Ready For Release

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • KDevelop 5.0 Appears Ready For Release

    Phoronix: KDevelop 5.0 Appears Ready For Release

    We haven't yet seen any official release announcement, but since yesterday a source package and AppImage binary have been out in the wild for KDE's KDevelop 5.0 integrated development environment...

    http://www.phoronix.com/scan.php?pag...elop-5.0-Ready

  • #2
    Been using the KF5 port since Beta1, even at work (for python though
    wasn't "rock" solid, but sure was solid...

    Really looking forward to trying out the clang based C++ parser.

    Comment


    • #3
      The AppImage doesn't use the system fonts, I guess they linked statically with Qt's fontconfig instead of using the system one...

      Comment


      • #4
        Interesting, how is it compared to QtCreator?

        Comment


        • #5
          I don't know why KDE still depending in too many stuff of QtWebkit, they need to move their apps to QtWebEngine, isn't so fun to depend of 2 version of webkit at same time (and compile them!)

          Comment


          • #6
            Originally posted by Azpegath View Post
            Interesting, how is it compared to QtCreator?
            Not comparable in my opinion. Qt Creator is perfect for pure Qt applications and even QML based stuff. Kdevelop works well with things like php and normal cmake/qmake with varying build folders and schemes. Qt Creator really forces you into one clean direction, but KDevelop has a lot more options. Both are very good just different. I like KDevelop for more complicated stuff or web dev stuff even.

            Comment


            • #7
              I used the git master version since the beta 1. I like it, but there are a lot of quirks and crashes still. A part of that, the clang based parser gives me the best autocompletion so far compared to many many other IDE. However there are cons too.

              Pro:
              * When using variable with type auto, it guesses the right type, every time. Even if the initializer of your auto variable if a complex template function.
              * When there's an error highlighted by the parser, there really is an error there.
              * When you hover a function, it highlight the correct overload, even when the overload is choosed with SFINAE
              * Most accurate and helpful autocompletion I tried so far. Need to fix bugs though, because it's making it less helpful.

              Cons:
              * It still very slow. Highlighting the code take several seconds, even on a powerful computer. Seems like there are sleeps in the code, but developpers are working on it: https://mail.kde.org/pipermail/kdeve...st/054612.html
              * Autocompletion is slow to appear, sometimes it's just faster to type the thing
              * Inside template classes and function, there are no autocompletion on dependent stuff. If you have a template classe that contains a std::vector of T, it won't autocomplete you, event for a push_back
              * When there is a LOTS of result in the autocompletion, the IDE seems to freeze, like when typing "gl" when OpenGL is included in the current file. Seems like the widget is too slow or something.
              * Sometimes, I still need to press F5 to reload the file to update the highlighting.

              Comment


              • #8
                Originally posted by gufide View Post
                * Sometimes, I still need to press F5 to reload the file to update the highlighting.
                Should be fixed a few weeks ago:
                https://git.reviewboard.kde.org/r/128480/
                https://quickgit.kde.org/?p=kdevelop...3f8b3c3cf5d5ae

                Comment


                • #9
                  Seems like I can still reproduce the error, and I updated few days ago.

                  The issue is pretty easy to reproduce, In my class, I just need to add or remove a function, and the highlight will be all screwed up. I will update KDevelop and comfirm the issue.

                  Comment


                  • #10
                    Originally posted by gufide View Post

                    Seems like I can still reproduce the error, and I updated few days ago.

                    The issue is pretty easy to reproduce, In my class, I just need to add or remove a function, and the highlight will be all screwed up. I will update KDevelop and comfirm the issue.
                    Yes, I got the last commits from today and the highlighting still screwing up easily. I will consider file a bug report.

                    Comment

                    Working...
                    X