Announcement

Collapse
No announcement yet.

Ubuntu PPA Updated With Mesa Git + LLVM 3.8 SVN

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu PPA Updated With Mesa Git + LLVM 3.8 SVN

    Phoronix: Ubuntu PPA Updated With Mesa Git + LLVM 3.8 SVN

    While Ubuntu 15.10 has Mesa 11.0 and it provides OpenGL 4 support for the Nouveau driver, it doesn't for RadeonSI. The issue is that in Ubuntu 15.10 is still an older version of LLVM that in the AMDGPU LLVM back-end lacks the needed support for OpenGL 4.0/4.1 compliance. Fortunately, a PPA has been updated for Ubuntu Wily with said support...

    http://www.phoronix.com/scan.php?pag...-LLVM-3.8-Mesa

  • #2
    I rush-installed Ubuntu 15.10 just to utilize this PPA for my AMD R9 390, but it doesn't work! I have a feeling that the AMD code isn't actually there for my card at this point...

    After installing this PPA and updating everything, Mesa still returns only OpenGL 3.0. Heck I can't even get OpenGL 3.1 or OpenGL 3.2 with RadeonSI even without this PPA. This is seriously frustrating, and leaves me with only Catalyst as an option.

    Comment


    • #3
      Originally posted by sabun View Post
      I can't even get OpenGL 3.1
      something is seriously broken in your setup. radeonsi ogl 3.1 is many years old

      Comment


      • #4
        Originally posted by pal666 View Post
        something is seriously broken in your setup. radeonsi ogl 3.1 is many years old
        It's been like this since day one I got this card. I've done fresh installs of Ubuntu 15.04 and 15.10 numerous times, and even with the default Mesa that comes with those I only get OpenGL 3.0.

        I know I must be doing something wrong, I'd really appreciate any help here. If you have any steps or information you'd like to get from me, let me know here and I'll grab that info for you.

        EDIT: My / is on my SSD and is the only thing I tend to format completely. I've had my Home directory on my HDD for about 10 months now without any reformatting. Could there be files from previous Mesa installs/PPAs that are screwing with my setup? Previously I tested r600g a lot with my old HD5750 card.
        Last edited by sabun; 10-13-2015, 09:20 AM.

        Comment


        • #5
          Originally posted by sabun View Post
          EDIT: My / is on my SSD and is the only thing I tend to format completely. I've had my Home directory on my HDD for about 6 months now without any reformatting. Could there be files from previous Mesa installs/PPAs that are screwing with my setup? Previously I tested r600g a lot with my old HD5750 card.
          Just add a new user, log into the machine with it and test Mesa would be the easiest I assume. Other than that maybe try OpenSuse or Fedora to see if you get OpenGL 3.3(+).

          Comment


          • #6
            "The issue is that in Ubuntu 15.10 is still an older version of LLVM that in the AMDGPU LLVM back-end lacks the needed support for OpenGL 4.0/4.1 compliance."

            Is not the only issue. LLVM 3.7 i386 is absent and the packagers have build mesa against 3.6 version, leaving all radeonsi users without OpenGL4. Right now Debian have LLVM 3.7 i386 in their Testing repos, but I am afraid that it missed the merging window...

            Comment


            • #7
              Originally posted by Namenlos View Post

              Just add a new user, log into the machine with it and test Mesa would be the easiest I assume. Other than that maybe try OpenSuse or Fedora to see if you get OpenGL 3.3(+).
              Just tried your first suggestion. Tested the default guest user and made a test user, both showcase OpenGL 3.0 only. Tried the live version (15.04 and 15.10) straight from my pendrive, still only shows OpenGL 3.0. I'll try OpenSuse on a live usb now, I don't feel comfortable with Fedora as it was really difficult last time I tried it.

              Comment


              • #8
                Originally posted by sabun View Post
                I have a feeling that the AMD code isn't actually there for my card at this point...
                I highly doubt that considering the R9 390 is just a rebranded R9 290 which last time I checked was well supported by the Mesa drivers even though it had a rather large performance difference with Catalyst compared to the other cards.I think rather though that this is probably some strange configuration issue caused by previously using the R600g driver as that doesn't support OpenGL 4 at all.

                EDIT:If you are going to use OpenSUSE to fix this make sure to use Tumbleweed as 13.2 uses the 3.16 kernel and a very old LLVM version which doesn't support OpenGL 4.
                Last edited by Bill; 10-13-2015, 10:23 AM.

                Comment


                • #9
                  Originally posted by sabun View Post
                  Mesa still returns only OpenGL 3.0. Heck I can't even get OpenGL 3.1 or OpenGL 3.2 with RadeonSI even without this PPA. This is seriously frustrating, and leaves me with only Catalyst as an option.
                  If you mean the OpenGL version string returned by glxinfo, it's OpenGL 3.0 for me too, however I have the latest RadeonSI drivers with 4.1 support. I don't know if it's a bug or a feature, for some reason 3.0 is returned even if you actually can have 3.0+ contexts. I recommend you running glewinfo (you have to install the glew package for that), and checking if everything under OpenGL 4.0/4.1 is listed as OK. That means real 4.0/4.1 support.
                  Last edited by yzsolt; 10-13-2015, 10:31 AM.

                  Comment


                  • #10
                    There are two different ways you can request an openGL context: compatibility mode and core profile. When you do the first one, you can use all functions that got deprecated with OpenGL 3+. This is recommended only for old apps. As the mesa website clearly states, you need to request a core profile context, if you want to use OpenGL features above 3.0:

                    OpenGL 4.1 is only available if requested at context creation because compatibility contexts are not supported.
                    So type
                    glxinfo | grep core
                    to see, which OpenGL version is supported.

                    Comment

                    Working...
                    X