Announcement

Collapse
No announcement yet.

GCC 8.3 Released With 153 Bug Fixes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GCC 8.3 Released With 153 Bug Fixes

    Phoronix: GCC 8.3 Released With 153 Bug Fixes

    While the GCC 9 stable compiler release is a few weeks away in the form of GCC 9.1, the GNU Compiler Collection is up to version 8.3.0 today as their newest point release to last year's GCC 8 series...

    http://www.phoronix.com/scan.php?pag...C-8.3-Released

  • #2
    I'm already testing it on Gentoo. No problems so far... )

    Comment


    • #3
      Originally posted by Brane215 View Post
      I'm already testing it on Gentoo. No problems so far... )
      try building qtscript-5.11.3

      Comment


      • #4
        Originally posted by mlau View Post

        try building qtscript-5.11.3
        I just did. I builds fine for me.

        Edit: I've also retried with LTO CFLAGS/CXXFLAGS/LDFLAGS.

        It compiles fine.


        Last edited by Brane215; 02-23-2019, 09:37 AM.

        Comment


        • #5
          Originally posted by Brane215 View Post

          I just did. I builds fine for me.

          Edit: I've also retried with LTO CFLAGS/CXXFLAGS/LDFLAGS.

          It compiles fine.
          You built it without JIT support?

          Comment


          • #6
            Originally posted by mlau View Post

            You built it without JIT support?
            True. With jit it fails at the beginning.

            It appears that gcc-8.x refuses to accept asm volatile combination.

            Even though it is in its manual page, so this should work.

            What's trhe workaround ? Usinng some speciall __attribute__(( )) or something else ?


            Comment


            • #7
              Originally posted by mlau View Post

              You built it without JIT support?

              Originally posted by Brane215 View Post

              True. With jit it fails at the beginning.
              Now that you know there's a problems, why not report it on the bug tracker where it may get some dev's attention? Right now nothing is reported, unless this old issue is your problem:

              https://bugs.gentoo.org/buglist.cgi?...-qt%2Fqtscript

              Comment


              • #8
                I didn't report it because I found the reference to a bug that is waiting to be resolved, mentioning "asm volatile" combination .

                Also, I ve understood mlau's post as a hint that not all is rosy with 8.3.0 and that he is waiting for a specific patch.
                And that he could possibly have a temporary workaround.

                Since I don't need qtscript, and had I needed it, I'd compile it with gcc-7.3.0, I just unmerged it and went my way...


                Last edited by Brane215; 02-23-2019, 01:06 PM.

                Comment

                Working...
                X