No announcement yet.

Hacking Express gate (Asus Splashtop)

  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Of course you don't need to symlink it, but thats the most easy way to add a (hidden) terminal without editing a file. That even works when the md5sum file is intact as you don't have to change existing ones. If I would not have seen that file before I would not have added that symlink


    • #62
      Originally posted by schmola33 View Post
      I'm trying to use ExpressGate to listen to my itunes music server.
      My version (actual for P5Q PRO - v1.3.3.1) allows me to make use of
      <Browser> <Games> <Photo> <Chat> <Skype>
      but no Music Player as mentioned here:

      Is this general matter, or do I have to activate the application?
      ExpressGate is installed on my HDD.

      Did anyone actually start a wiki about hacking splashtop, or is there any step by step howto hack the img (and where do I get it?) out there i cant find?

      The music player is not included in ExpressGate v1.3.3.1; I managed to find it when I used ExpressGate for Asus laptops; sorry I don't remember the version; all I did was to copy the file on my USB that has ExpressGate; for you it will be ASUS.SYS folder. The file is va-music.sqx, The music player can play only files that are stored on you computer.


      • #63
        Another question: how are you compiling drivers for splashtop?

        From inside a 32bit debootstrap I've tried compiling the same kernel version that it's runign and insmod always errors
        insmod: cannot insert '/lib/modules/': Invalid module format (-1): Exec format error
        Also how did you modify the screen resolution script? Even when I add more resolutions inside the actual script it wont recognize them (eg export DI_HAVE_RES_LIST). I've seen this being discussed before but never saw exactly how to do it.

        A couple things I found out: You can change the firefox scripts to use a default profile and it makes it not suck, also firefox 3 (er at least iceweasel 3) isn't very hard to install and runs much better.

        kde 3.1 is installed but is largely broken (konsole works). I think it might be possible to take out kde and either install a newer, more complete version of kde or use xfce4. That way apps would integrate better.

        Also I think it would be cool to set up some webspace somewhere to host modified versions of splasgate. The technology that runs it is pretty cool but the default splashgate sucks IMO. It's so small/simple though that making *clean* overhalls is very easy. Eg completely removing everything associated with firefox2 and installing firefox3 or doing the same with kde3.1 (I would assume all of asus's special apps would be detected by other desktops, if not there aren't very many of them to add).
        Last edited by Legion; 10-09-2008, 04:27 PM.


        • #64
          Originally posted by Kano View Post
          Btw. it is relatively easy to add command line apps in new containers, when you just create a sqx analog to the already existing ones. Just need to figure out how to add em to the menu. Also there is a nice trick to run a root terminal: just create a new pack with rxvt or whatever you like and add a symlink to gnome-terminal. Then you just have to press ALT-F1 and you are root. No need to hack another package...
          I follow your posts since long time, now I can do some experiments on my new eeebox and I need to know what files to add and how to create a symlink to have a root terminal in splashtop: please, could you help me?

          Thanks in advance

          Rome, Italy


          • #65
            Splashtop on the Asus lptops

            I believe the Splashtop on the laptops are on a ROM chip. Can this be modified? What tools would I need? I would like to access my Home Server as well as Print.


            • #66
              Its internal usb storage, nothing with ROM or running from hd partition.


              • #67
                Hi guys

                It's gone awfully quiet in here? Holidays?

                On a more serious note. I have the Asus P5Q MB. I want to install the Express gate on USB stick. But ... During install the selection for other drives is blocked? Only c:\ ... is allowed

                Where can I get the files required to make Splashtop work from USB stick. Can someone upload them?

                The main reason is that I read somewhere that the Drive Expert functions are also available from Splashop?


                Enjoy the festive season.


                • #68
                  I follow your guide to make Splashtop on Usb and it works fantastic. Now i want to add some apps to Splashtop like a music player, but i don't understand how i can make it. I read that some users add some programs and a gnome terminal but what i've to do? Thanks a lot for your work, it's amazing.
                  Happy new year to everyone


                  • #69
                    Xpress Gate SSD?

                    Hi everyone.
                    i finally got my P5Q Deluxe with an EG SSD. So after a short time, the integrated PidGin Client doesn't connect to my ICQ Acc. The reason is that ICQ changed something in the protocol.
                    The latest Update on the Asus Website doesn't fix the problem.

                    So i tried to modify it by myself.

                    For the SSD you need the Asus Express Gate Updater (only runs in Windoze)
                    and an Update file.

                    The latest update File i found was ST_ASUSEG00_256MB_v1.3.3.1_20080815.DFI

                    this is an normal gZip file. Just rename and extract it. But then i got an .img file (size 262MB) wich i can't open with any application i tested

                    Daemon Tools / Iso Buster / UltraIso / PowerIso / IsoMagic / Virtual CloneDrive / and some Linux tools.

                    So i checked the MIME Type in Linux and i replies that:

                    [email protected]:/media/disk# file -i ST_ASUSEG00_256MB_v1.3.3.1_20080815.img
                    ST_ASUSEG00_256MB_v1.3.3.1_20080815.img: application/octet-stream

                    so i can't figure out what kind of File this is. Can anyone help me??

                    BTW i asked Asus for support (was just a try! ) and they replied this to me (was in German so i translated it)

                    Dear Mr S,

                    you are not allowed to modifiy the Express Gate. So we can't give you any Information. The problem with the Chattool (Pidgin, which doesn't work with my ICQ account) will be forwarded to our Team in Taiwan, and we are hopefull that there will be an update soon.

                    First i thought the are kiddin me, i thought EG and Splashtop are OpenSource, bt after a quick search i found this:

                    If i realy understand this it means that Asus and Splashtop violate the GPL.
                    1 more Reason to hack EG

                    and i want an xterm...

                    so long guys....


                    • #70
                      When you looked better you should have found my solution for this - to create new DFI


                      Extract is even simpler. But you have to remove the header + md5sum (48 bytes in front). You should do the other step before too, to get the header - but you only need the header once. This overwrites the IMG:

                      zcat FILE.DFI|dd ibs=48 skip=1 obs=1M of=FILE.IMG
                      Last edited by Kano; 01-24-2009, 08:04 AM.