No announcement yet.

Hacking Express gate (Asus Splashtop)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Hmm, thats very strange. I find that the safest way to do it is to just run those commands, that way you don't even need a va-customres.sqx file. Of course thats just personal preference.

    The fact that it is missing the resolution selection page is very strange. Give me a few minutes and I'll work out an alternative, I know there is a command that can be called in order to set the resolution manually (the same one that the interface calls) which you may be able to use.

    You won't need to create a DFI image, just compress the files into SQXs and paste them into your ASUS.SYS directory and it should work. Also keep in mind that if you modify and of the original SQX files then you will have to update/patch the version file.

    There are 2 ways of doing this:
    1. Remove everything after the first 32 bytes:
    dd if=version of=newVersion skip=0 bb=1 count=32
    2. Use my application to create a new version (See my tutorial)


    • Okay, try this. I haven't had a chance to test it but it should (hopefully) work:

      In ubuntu create a new document called and enter the following into it:
      import os
      import string
      import Util
      import VAEnv
      def main(self):
      Copy this file onto a memory stick or something that you can access from within SplashTop
      • Open Term
      • type: export DI_HAVE_RES_DDC='yes'
      • type: export DI_HAVE_RES_LIST='640x480x24x60,800x600x24x60,1024 x600x24x60'
      • type: python (Path to your file)
      • Restart

      I hope it works, basically it is trying to emulate what the OK button on the Resolution tab does, albeit a LOT more simply


      • Oh, you may have to copy your file to /usr/lib/dvm-config/pyconf for it to work. Not sure about exactly how Python will see that (First time using it LOL)


        • Again, thank you for your efforts.

          Following your instructions, I created the file and copied it to /usr/lib/dvm-config/pyconf. Invoked the script and it completed without errors. Ctrl-Alt-Bakcspace to restart X. No change. The file was still there.

          My version of EG appears to be more limited than others. It announces itself as v. I noticed that Terminal does not show up on the panel initially. Only after I launch one of the other apps does it become available, along with the system tray.


          • Some more experimentation may have shed some light on the issue. I added Puppy Linux, because it has a pretty good Xorg configurator. It correctly identified the screen resolution and constructed xorg.conf with the proper settings. Yet, when it starts X, resolution remains at 800x600. It may be that the driver just refuses to push the Intel N10/ICH7 chipset above that, regardless of what it's instructed to do.

            I see that there are several updates on Asus's ftp site, including a "V15179" dated 03/26/2010. Maybe an update will give me the necessary capabilities. Worth a try.


            • Yeah, updating it may be worth a try. Alas, if it is a hardware or driver limitation then I'm not quite sure how to help you, Kano may have a better idea. Maybe injecting driver modules or something like that?

              Anyway, I do hope that you can get it working with the update.


              • Tried upgrading my EG with a couple of the versions from Asus, but both ended up with a corrupt display. Seems like the system is running underneath, because Ctr-Alt-Del reboots it. I also tried dropping some files from the new version into my old one, but it didn't like that either. Even a theme file caused it to lock up.

                Will keep tinkering and if I figure something out I will report back here.


                • Thats very strange, I did a bit of looking around and it seems that there are no compatible ExpressGate Lite updates for your laptop. In fact Asus doesn't list ANY ExpressGate versions for your laptop.
                  My assumption would be that ExpressGate (lacking the required system setting files) is setting your resolution to the default 1024x768 which will cause your screen to bomb out. The only way around this (AFAIK) would be to add a custom-res.sqx file in the same way that I show in my tutorial, except you will have to include everything that is contained within the standard ones as well as your own resolution settings.
                  You could try downgrading your version to its original one, then using the terminal copy the contents of
                  to a memory stick which will then allow you to see the exact settings that you need to put in there.

                  Best of luck,


                  • I tried hooking up an external monitor to see about the resolution, but it shows the same static as the laptop LCD (Ubuntu will drive the external screen to 1920x1080).

                    It looks like EG-HDD is similar to the "frugal install" setup used by other distros. My upgrade procedure for the new EG version was to just install it under Windows on another machine, then copy the ASUS.000 and ASUS.SYS folder over. Of course, I have a copy of the originals, and restoring is just a matter of putting those back.

                    I think trying your custom-res.sqx hack would be a good next step. Using the EG terminal I mounted a partition on the drive and copied /etc/models.d over. I wonder if I should work with the "default" directory, create a "1001P", or both?


                    • Hmm, I'm begining to wonder whether or not its the actual version of ExpressGate which is causing the problem.

                      Did the upgrade method that you used work?

                      I'd copy the contents of the "default" directory into a new one called "1001P" since mounting a va-customres.sqx file will not overwrite existing files. Then modify the contents to match what your laptop supports.