Announcement

Collapse
No announcement yet.

The Leading Cause Of The Recent Linux Kernel Power Problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bwat47
    replied
    So I take it this bug doesn't effect you if you have on processor graphics such as sandy bridge?

    Leave a comment:


  • stqn
    replied
    I've just tried on my Gigabyte H55N-USB3 mobo, no improvement at all here. Still 49W idle (even after setting /sys/module/pcie-aspm/etc. to powersave.) No improvement either when the CPU is in heavy use, or when running "vblank_mode=0 glxgears".

    I don't have any PCIe card though, if that matters.

    Leave a comment:


  • stqn
    replied
    Originally posted by ahlaht View Post
    Code:
    $ sudo echo powersave > /sys/module/pcie_aspm/parameters/policy
    bash: echo: write error: Operation not permitted
    I think you should type that as root, not with sudo. BTW I'm not getting this error, but:
    Code:
    $ sudo echo powersave > /sys/module/pcie_aspm/parameters/policy 
    bash: /sys/module/pcie_aspm/parameters/policy: Permission denied
    However, as root, I'm getting what you wrote:
    Code:
    # echo powersave > /sys/module/pcie_aspm/parameters/policy
    bash: echo: write error: Operation not permitted

    Leave a comment:


  • AdamW
    replied
    FWIW, neither of my main systems appears to have the bug. I get:

    [[email protected] cheese (f15 %)]$ cat /sys/module/pcie_aspm/parameters/policy
    default performance [powersave]

    indicating that powersave is the current policy, I guess, on both my laptop (Sony Vaio Z) and desktop (Asus P8P67 Deluxe mobo), running 2.6.38 kernels with no special parameters.

    Leave a comment:


  • Shining Arcanine
    replied
    Originally posted by Rabauke View Post
    As far as I got it now:

    If the kernel disables ASPM, it's a BIOS bug (on newer systems)?
    I got a Thinkpad 410. So I request Lenovo to fix that?
    I have a Lenovo Thinkpad T520 and I have the same situation. I think I will call Lenovo about this.

    By the way, power consumption dropped from about 26 watts to 15 watts, which is about a 40% difference. Estimates on battery life increased from 5 hours to 8 hours, which is in-line with the battery life figures that I have seen on review sites. This is a new Sandy Bridge Optimus notebook that I purchased last month, so I was affected by the regression on day 1.

    Leave a comment:


  • grotgrot
    replied
    Intel BIOS too?

    My motherboard is an Intel DP55WG and the BIOS is written by Intel.

    ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
    Another possibility is that the kernel code that makes the above decision isn't quite right.

    Leave a comment:


  • Nille
    replied
    Originally posted by Xake View Post
    http://smolt.fedoraproject.org/static/stats/stats.html

    This site also tells a story...
    "System Product Name", "System Name" and "To Be Filled By O.E.M. To Be Filled By O.E.M." are all the predefined values, and supposed to be filled in by the BIOS developers before shipping. If they cannot even fill this in....
    To Be Filled By O.E.M. sounds like ASRock.

    Leave a comment:


  • hircus
    replied
    Originally posted by ahlaht View Post
    The ASPM-related messages from kernel can be very confusing, but there is an easy way to test if ASPM is active: Write something to /sys/module/pcie_aspm/parameters/policy
    That's a good way to find out before rebooting the system, thanks. In my Sony Vaio EB's /var/log/dmesg, ASPM only appear once -- and that's from an older kernel. But the policy file indeed cannot be modified. I'll try forcing it when I get home.

    To the earlier poster with a Vaio -- which model? I'm guessing the top-line Z and S models might have a better BIOS than the ones in the budget lines.

    Leave a comment:


  • ahlaht
    replied
    The ASPM-related messages from kernel can be very confusing, but there is an easy way to test if ASPM is active: Write something to /sys/module/pcie_aspm/parameters/policy

    I get this on new kernels WITHOUT pcie_aspm=force:

    Code:
    $ sudo echo powersave > /sys/module/pcie_aspm/parameters/policy
    bash: echo: write error: Operation not permitted
    On older kernels (I tested 2.6.36) or with pcie_aspm=force the value can be changed.

    Leave a comment:


  • Xake
    replied
    Originally posted by agd5f View Post
    Coreboot is not a magic bullet.
    It may not be a magic bullet, and is still a hell if you do not have the hardware specs, but it is a hell of a lot easier to fix yourself then a binary blob...

    Leave a comment:

Working...
X