No announcement yet.

Ralink Adds RT5390 Support To Open WiFi Driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • Ralink Adds RT5390 Support To Open WiFi Driver

    Phoronix: Ralink Adds RT5390 Support To Open WiFi Driver

    Back in September there was the major victory for the open-source and Linux hardware support communities when Broadcom open-sourced an 802.11n Linux driver after years of their WiFi chipsets being notorious under Linux. There's another wireless chipset vendor now getting more serious about open-source driver support too and that's Ralink. They've now contributed patches to the rt2x00 driver project that enables their new RT5390 chipset family to be used by this open-source Linux wireless driver...

  • #2
    Probably too late for Linux 2.6.38 I guess, but maybe Ubuntu can backport it (GPL drivers were avaible for that device as a tarball since December).

    This is the chip that is, among other notebooks, used in the pretty popular-since-CES HP Pavilion dm1z, powering the new AMD Fusion platform.


    • #3
      Ralink has played well with FOSS community for a long time

      Ralink has always had excellent open source support for their wireless devices. At one point (early 2000s) Ralink was the ONLY choice for FOSS wireless drivers. Back then there were absolutely no Linux drivers for Atheros, Intel, Realtek, Broadcom or TI/Nokia.


      • #4

        i bought an USB stick with a RT2800 to feed the iPod Touch 3rd Gen and i'm really sorry that i did not opt for a slightly expensive router that had wireless.

        the thing is that the stick works ok, almost out of the box support on Linux although that site does not mention Linux for this perticular model, also Windows 7 is ok too
        on Linux it just needs some firmware blobs and it's rolling.

        the problem comes when i want to connect another USB device, a measly USB memory stick ( 4Gb Sandisk ), and it goes like this:
        1. plug it in ( say front USB port ): memory stick led blinking continously, stick detected as dmesg says but KDE is not notified that a new device is connected also dmesg spammed with: usb 1-9: reset high speed USB device using ehci_hcd and address 5
        2. use the second front port: stick appears as mountable in KDE, click open in Dolphin, Dolphin and KDE freezes, i can still switch windows with the keyboard but i can't access KDE menus/icons, unplug USB stick to recover KDE, maybe dmesg spammed as point 1
        3. use a back case port via an USB extender: maybe it works maybe it's like point 2 above or maybe point 1
        4. if it did not work: repeat trying the ports until it works

        Note: in Windows XP and 7 this stick works ok on any USB port and it works ok in Linux when the wireless stick in NOT plugged


        • #5
          Ralink has had open source support for almost all (if not all) of their devices for years now. They took a lot of flack from the open source community for releasing a driver that had an abstraction layer so they could share their source code across OSes rather than writing a Linux driver from scratch. rt2x00 was based on the source code Ralink previously released. While it's nice that Ralink is working in the upstream driver, it's also likely a lot more work for them since they can no longer share code across supported OSes.


          • #6
            They should fix support for rt35xx devices as well. rt2x00 code for these has been broken since it was introduced in 2.6.34, and the latest 2.6.38 sources even explicitly recognize that it's broken, saying something like "this is just for educational / research use" because the driver doesn't actually work.

            That kind of thing has left a bad taste in my mouth regarding the quality of Ralink's source. Couple that with the fact that even their binary blob drops only work if you use one particular version (with much newer and older versions all being broken), and I'm not too confident that they really know what they're doing. I used to get kernel panics all the time trying to use rt2800sta.

            I've tried three different usb 2800-based devices and one usb 3572-based device, and it's always a struggle to get them working -- the rt2x00 project has never done anything right for any of these (in my experience), and even their tarballs are hit or miss, with the wireless spuriously (and permanently) dying after hours of use, until you reboot.

            Heh, makes the mesa drivers look downright stable Maybe it's just that they fail at USB, though; has anyone had a rock solid experience with PCI-E or PCI devices? I'd love to know if this isn't the status quo for Ralink.


            • #7
              Originally posted by allquixotic View Post
              even their binary blob drops only work if you use one particular version
              The blobs Ralink used to release were fully open source. I don't think they ever did NVIDIA-style binary-only releases.


              • #8
                Originally posted by allquixotic View Post
                has anyone had a rock solid experience with PCI-E or PCI devices? I'd love to know if this isn't the status quo for Ralink.
                No, the rt2860 (PCI i think) in my Netbook is not stable at all, often i have to reboot my Ubuntu 10.10, just to get wlan to work again after suspend. And still only 802.11g instead of 802.11n...
                I doubt the situation will ever improve though (the device being relatively old now), in future i would never choose a ralink wlan device for use with linux, but sometimes you don't have a choice...


                • #9
                  Originally posted by allquixotic View Post
                  has anyone had a rock solid experience with PCI-E or PCI devices? I'd love to know if this isn't the status quo for Ralink.
                  I have had many ralink PCI cards. They have always been rock solid for me and gave me far greater range then any intel/atheros/broadcom card that I tried. I have even used a couple of them to establish a bridge over a city block (with a good external antenna).


                  • #10
                    Well I seriously hope,

                    that they also do something about older chipsets from the rt2500 family.

                    I've (still) got two of them, one pci2500 and one usb2500. The pci wireless card did never work at all and still doesn't with even the most recent ubuntu kernels and the wireless signal strength for the usb card is just absurdly bad - if your computer is not sitting DIRECTLY next to your source, you do not get any signal at all. Leaving the room and the signal is gone.

                    I know the rt2500 chipsets are old, but compared to similar old ones from intel, dell and broadcom, I just can advice avoiding ralink chips if possible. Since I turned to Broadcom and Intel, the wireless is just as good as under windows.