Announcement

Collapse
No announcement yet.

Linux Workaround Coming For Better s2idle Resume On More AMD Lenovo Laptops

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • make_adobe_on_Linux!
    replied
    How can decade old Apple laptops sleep for many weeks and still have battery life to spare (first hand experience). Does anything even close to that exist today at Linux could take advantage of? Doesn't make sense; seems like a hardware-firmware issue.

    Leave a comment:


  • oleid
    replied
    Originally posted by tuxd3v View Post
    Many thanks for your comment.
    It really gives me some hope.
    I love that laptop, and I also use Debian!

    I don't recall now,
    But I remember that they found a way to do suspend, but it was not in the most energy saving way, does you know about that?
    Thanks in advance.
    That firmware setting allows the usage of the "classic" suspend variant - s3 or however it is called. Not the new stuff. I'm not sure which one is more efficient.

    Leave a comment:


  • tuxd3v
    replied
    Originally posted by oleid View Post
    For the time being, update to their latest firmware and switch to "Idle type = Linux" (or similar in their EFI).
    That way, suspend/resume works on Linux. I'm using such a notebook as my work-laptop (configured by our IT) and it works fine with Debian/stable.
    Many thanks for your comment.
    It really gives me some hope.
    I love that laptop, and I also use Debian!

    I don't recall now,
    But I remember that they found a way to do suspend, but it was not in the most energy saving way, does you know about that?
    Thanks in advance.

    Leave a comment:


  • lateo
    replied
    Originally posted by bearoso View Post
    Have a T14s. There's a switch in the bios options to use real S3. Works fine once you know it's there. Instant wakeup.
    p14s : Explicit choice between "Windows" and "Linux" for the relevant option in the graphical "bios".
    [...] The feeling discovering the option wasn't half bad ^^'

    Leave a comment:


  • ntropy
    replied
    I am on a Tuxedo Pulse 14 with a 4800H and thats the best laptop I ever had. Not that its ultra fast and I can do GameArt and even small Game dev on it, suspending it is a dream. Never had an issue in one year.

    Leave a comment:


  • oleid
    replied
    Originally posted by tuxd3v View Post
    I hope they solve once and for all, this bugs on amd platforms..
    Because I am waiting to buy a Lenovo L14 gen2, but I will not until they decide to solve this mess.
    For the time being, update to their latest firmware and switch to "Idle type = Linux" (or similar in their EFI).
    That way, suspend/resume works on Linux. I'm using such a notebook as my work-laptop (configured by our IT) and it works fine with Debian/stable.

    Leave a comment:


  • mdedetrich
    replied
    So glad this is coming through, also with a t14s that had these issues although as mentioned by other people you now have an option in the bios to switch the sleeping option to a "Linux" one.

    In any case this is useful if you plan on dual booting the laptop.

    Leave a comment:


  • bearoso
    replied
    Have a T14s. There's a switch in the bios options to use real S3. Works fine once you know it's there. Instant wakeup.

    Leave a comment:


  • tuxd3v
    replied
    I hope they solve once and for all, this bugs on amd platforms..
    Because I am waiting to buy a Lenovo L14 gen2, but I will not until they decide to solve this mess.

    Leave a comment:


  • dragonn
    replied
    Originally posted by mb_q View Post
    I'd rather have S3/deep/s2ram back than this Windows nonsense; unfortunately many laptops have S3 kicked out of firmware, sadly seeming AMD ones especially.
    It often is not removed from the firmware but only commented (yes, some laptops have the S3 symbol renamed to _S3) or removed from the ACPI table. That can be patched by loading a custom patched ACPI table when loading the linux kernel. Many users fix this way the stupid s0ix/s2idle non sense by jest going back to S3

    Leave a comment:

Working...
X