Announcement

Collapse
No announcement yet.

Civilization 5 broken with glibc 2.26

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Civilization 5 broken with glibc 2.26

    Hi everyone,

    Civilization 5 has been relatively unstable for me lately on Linux, but it looks like we'll have great difficulties to run this game in the future.

    I'm using Debian SID, and the recent update to glibc 2.26 kills the game completely due to a compile alignment issue. I found all the details in a 4 month old Fedora bug: https://bugzilla.redhat.com/show_bug.cgi?id=1471427

    Does anyone have a nice solution for this issue? I've tried to report some issues in the past to Aspyr, but they were very very unhelpful.

    Any other Civilization 5 players around?

    BTW I am using the very latest version with all extensions and DLCs as available in Steam.

  • #2
    Welcome to gaming on Linux. Expect similar experiences in the future

    Unless the studios take the trouble to keep their game clients maintained.. which generates them no revenues and keeps devs off from making new games.

    Comment


    • #3
      This is a gcc bug causing a miscompilation of 32bit glibc: Poke your distro to patch GCC for bug 81481, and then rebuild glibc (or better: all other 32bit libraries as well).
      It solved the crashes for me.

      Comment


      • #4
        Well, thats great! Thanks mlau for the info!

        This correction should come with the recent release of gcc 7.3, so this issue may disappear soon

        In the meanwhile I've installed it on wine.

        Comment

        Working...
        X