Announcement

Collapse
No announcement yet.

Wine-Staging 2.16 Released With More D3D9/D3D11 Bits

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wine-Staging 2.16 Released With More D3D9/D3D11 Bits

    Phoronix: Wine-Staging 2.16 Released With More D3D9/D3D11 Bits

    Building off last week's Wine 2.16 bi-weekly development snapshot, the crew working on the more bleeding-edge/experimental Wine-Staging branch have released their v2.16 update with various features tacked on...

    http://www.phoronix.com/scan.php?pag...e-Staging-2.16

  • #2
    64-bit syscall thunks in the fake ntdll.dll
    fake ntdll.dll are thunky!

    PS My first grammar nazi attack ever!

    Comment


    • #3
      - Edit for my previous reply (cause that can't be done when they are in moderation ). Seems syscall thunks are a thing! Sorry to Michael on the unfounded grammar attack but I still stand by that they are a thunky thing

      Comment


      • #4
        Lately Wine releases fix less and less bugs.
        I wonder if this is a sign that it's getting mature, the progress is slowing down, or maybe they're preping for some major changes...

        Comment


        • #5
          It is truly amazing seeing games like The Witcher 3, Overwatch, and GTA V running in wine.

          Comment


          • #6
            In this wine staging version sims 1 works however character rendering error still present



            Comment


            • #7
              On a related situation, has anyone using Gallium Mesa drivers actually use Wine? Cause mesa has a core profile problem. Anyone using Padoka PPA or Oibal PPA or just whatever comes with Ubuntu or Mint have tried running CEMU through Wine? Cause it works fine for Nvidia users using binary drivers. It won't for Radeon or Intel users with Gallium Mesa. Though someone was actually able to fix it by patching Mesa, but then you lose out on Padoka or Oibaf updated drivers.

              https://github.com/mikakev1/mesa_mild_compatibility

              It even effects Linux applications like RBDoom3BFG, where with Gallium Mesa it wouldn't work without a proper core profile.

              https://github.com/RobertBeckebans/R...BFG/issues/386
              Last edited by Dukenukemx; 09-07-2017, 11:37 AM.

              Comment


              • #8
                Originally posted by Dukenukemx View Post
                On a related situation, has anyone using Gallium Mesa drivers actually use Wine? Cause mesa has a core profile problem. Anyone using Padoka PPA or Oibal PPA or just whatever comes with Ubuntu or Mint have tried running CEMU through Wine? Cause it works fine for Nvidia users using binary drivers. It won't for Radeon or Intel users with Gallium Mesa. Though someone was actually able to fix it by patching Mesa, but then you lose out on Padoka or Oibaf updated drivers.

                https://github.com/mikakev1/mesa_mild_compatibility

                It even effects Linux applications like RBDoom3BFG, where with Gallium Mesa it wouldn't work without a proper core profile.

                https://github.com/RobertBeckebans/R...BFG/issues/386
                I would like to know if it is possible to lie to applications by using an env var regarding the "compatibility profile" support, I know the OpenGL version can be override, but can the compatibility profile be override too?

                Comment


                • #9
                  Originally posted by pinguinpc View Post
                  In this wine staging version sims 1 works however character rendering error still present



                  Wow Sims 1 is finally working in Wine? That game hasn't worked since the Cadega / Transgaming port.

                  Comment


                  • #10
                    Originally posted by JPFSanders View Post

                    I would like to know if it is possible to lie to applications by using an env var regarding the "compatibility profile" support, I know the OpenGL version can be override, but can the compatibility profile be override too?
                    MESA_GL_VERSION_OVERRIDE=4.5compat

                    Comment

                    Working...
                    X